I'm trying to do a complete backup of all data on my Samsung Galaxy S4 before I send it in for repairs.

Even though the screen is completely black and does not work (very little touch abilities), I have the Galaxy Smart Dock, which lets me output the screen via HDMI and control the phone with a mouse.

I removed the lock screen, installed Kies, then connected the phone to my computer.

Unfortunately, at one point, my phone switched from MTP to PTP, and now I cannot switch back to MTP (which Kies requires).

Everything online says to just connect the phone to the computer and swipe down to select the connection mode - I cannot do that because the screen is broken.

I also do not see any "three dot" option in Settings / Storage to change the USB Computer Connection.

Is there an option I'm missing? Am I SOL?

Again, I have full control of my device through the media dock, I just do not have that control when the phone is connected (via USB) to my computer.


7 Answers 7


If your phone is like mine, this option does not exist in any of the Settings menus. First, connect your phone to your PC via the USB cable. (If it is already attached, remove and reattach). Watch your Notifications bar at the top of your screen and you will see a USB symbol appear. Pull down the Notifications and viola, there is the option to change it back to MTP.

  • I am unable to do that because my screen and digitizer are both broken. I have control of the phone through the media dock (using the HDMI out and a mouse), but to connect the phone to the computer, I have to disconnect the phone from the media dock, which means no more device control.
    – Michael
    Sep 22, 2014 at 4:59

i know you have probably fixed this by now but if not try typing *#0808# into your phone this will bring up a menu where you can select mtp


Change the cable. I had a noname cable and did not worked, it only charged and the phone was not available as storage. After replacing cable with a trusted one (BB or Samsung i tried) it worked.


try typing the following into your Samsung phone to get access to a hidden USB connection menu


  • Can you expand on this answer a tiny bit to explain what access codes are and how someone can check them?
    – Amanda
    Feb 1, 2018 at 18:50
  • this is actually working answer. Jun 8, 2018 at 13:58

I am sure this is to late for you but hopefully will help someone else out.

Some launchers for example Nova have 'actions' that you can add as shortcuts by long pressing your homescreen. One of these actions is 'expand notifications'. Now you can simply select this icon to pull down the notifications.

This can be useful for using the phone with gloves too when pulling down the notifications can be annoying.

  • Thanks for the suggestion, but my problem isn't opening the settings menu, it's the fact that my digitizer is broken, so even if it were a button, I wouldn't be able to access it when the phone is connected to the computer.
    – Michael
    Nov 11, 2014 at 17:47

This solution should work.

First, for Michael, note that the OP bought a Smart Dock. That will be crucial for you. It is not free, but the price you pay will benefit you in other ways:

  • purchase a Samsung Smart Dock. I've seen them on Amazon for around $60
  • mount your phone in the Smart Dock

Now you have:

  • external HDMI connection for the screen
  • power for charging your phone
  • Several USB ports for PC connection and more

All simultaneously.

It's the only connection I've seen that does screen + USB at the same time. Other cables sometimes claim it but I've never had one that worked properly.

Now, once you have the Smart Dock, you're ready to go.

Note: the OP already had a Smart Dock but could not get it to switch to MTP mode. That sounds mighty strange! As soon as you plug the phone into your PC with a valid data cable you should see it recognize the USB connection.

If you don't, one of two things is wrong in my experience:

  1. Have you installed the Samsung Kies 3 app on your PC, and have you updated the driver? (That's an option in "Tools") If not, the PC likely will not recognize the phone, and the phone will not know it is connected to a PC.

  2. Are you certain you have a good data-USB cable? A charging-only cable will not work. (Most micro USB cables are fine, although an old one may have a bad pin you would not notice except for this problem.)


Check the USB connector on the phone. I had a lot of trouble connecting my GS4 (it would charge but not be recognized by the PC) until I found out there was a LOT of pocket lint down inside the connector area. I cleaned it out gently with a toothpick and after that it hooked right up to the PC. I think the USB cable connector wasn't getting completely inserted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .