2

I use Samsung Galaxy S4 Mini Android Phone, its MTP mode is not working just after I plugged it in to another PC some time for just USB charging.

I re-installed the driver on my PC and removed the device, re-installed the driver again, and tried some methods like these.

But it was not working with my PC, however, I can view the files on the smart phone with the ADB command on the command prompt.

I am not sure what the situation is.

I cannot connect it via MTP, and its driver failed to install, showing exclamation mark on the Windows Device Manager.

However, I can view the files with ADB command, but not convenient as MTP connnection.

Can I recover this device to be shown without exclamation mark? Everytime when I connect the phone, My Windows 7 tries to install the driver but failed, but ADB works.

I searched many internet sites for the solution, but I tried regedit to remove "UpperFilters", deleted and re-installed driver, tried PTP mode (even it seems not working), and etc.

I am also thinking there might be a problem on the phone itself. (Because I have rooted it once)

Can I get some help from any expert? Thanks very much in advance.

  • Are you using windows 7 or windows 7 sp1 ? – samnaction Sep 22 '14 at 6:09
  • I am using Windows 7 SP1. It was working, now it isn't. – Shanion Sep 22 '14 at 6:38
  • I assume you tried connecting in different usb port, rebooting PC, installing samsung driver etc.Try updating windows media player to 11 – samnaction Sep 22 '14 at 7:29
  • I checked the version of Windows Media Player, it was 12.0.7601. For Windows XP users, Windows Media Player Version may be a reason, but I am using Windows 7. Can 12.0 be a problem? I re-installed Samsung driver twice. I am going to re-try with a different USB port, I am not sure the port might be a problem because I tried on a different PC already. – Shanion Sep 22 '14 at 9:49
  • forum.xda-developers.com/showthread.php?t=867518 you can even try this – samnaction Sep 22 '14 at 10:45
1

I had tried tons of proposed solution and it seem doesn't work for my Samsung Note 3. However i finally solve without installing/uninstalling anything.

Problem Solved as following;

1) Reboot phone to Recovery Mode.

2) Wipe Cache Partition.

3) Restart phone and connect to PC.

Bum!!! Window successfully installed your MTP driver.

1

From this xda post

  1. Plug in device
  2. Open device manager
  3. Right click the ADB device and select update
  4. Choose the manual option
  5. Select the option to choose from list of drivers
  6. Select MTP, go and it'll work!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.