1

My carrier keeps sending the voicemail notification to my device. I can force-stop the phone app (makes the notifications go away), but EVERY SINGLE TIME the device reboots or do something phone-related, boom, its back.

In the app info, the checkbox for notifications is shaded.

Is there any way to make the checkbox unmarked?

I have root, terminal emulator and ADB to play with.

0

Since you've root access, you can easily allow or ignore the notifications of any app.

  1. Install a file manager having root explorer feature such as ES File Explorer or MiXplorer.
  2. Go to /data/system and open notification-policy.xml.
  3. Add <package name"PKG_NAME" /> between <blocked-packages> and </blocked-packages>, such as:

    (Click image to enlarge)

    IMG:

    Replace PKG_NAME with the package name of the app whose notifications you don't want to see. See View app's full package name?

  4. Save the file and reboot the device. The "Show notifications" checkbox would now be seen unticked.

    IMG: IMG:

There's also an alternative approach which didn't work for me. You may give it a try though. Find it here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.