I have a bit of a mixed problem in my Xperia arc s. I started by trying to install apps, and I got that message saying "There was a problem parsing the package". I checked "unknown sources" in settings and made sure that I matched the minimum sdk required or higher and still the same message.

After that I tried to install a different rom, but whenever I flash a kernel I get stuck in CWM and the rom's zip file is not found! Even when I open the sd card from windows explorer it seems that the zip file has disappeared.

I used flashtool to get back to the original rom, but again whenever I try to install an app I face that "Parsing Package" problem again!

So what's wrong here? How can I get my phone working again so I can install apps?


It sounds like you have a bad ROM install. You should try completely wiping the phone and re-installing the ROM from scratch. Make sure to clear the cache, the dalvik cache, and system. Then flash the original ROM back on.


It seems the problem was with the sd-card, any new files weren't recognized on it so when i switched it with a new one the problem was solved though i can't format it till now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.