I have a Samsung Captivate.

This week, it's wi-fi stopped working.

To be more precise, it's wi-fi recognizes there is a wi-fi router nearby (my home's), and tries to connect. But it immediately disables and tries again in an unending loop.

  • I have not tried connecting on another hotspot.
  • I have installed a couple of programs this week, but I don't remember any of them being wi-fi related.
  • I recently put JuiceDefender on aggresive mode, but now I've disabled it, and wi-fi still doesn't work.
  • Tried enabling/disabling Flight Mode, but no success.
  • I've restarted my phone a couple of times.

UPDATE (04/15/2011)

I managed to connect to a nearby hotspot, so I'm guessing the router is the problem. It is a 5yrs+ old router (linksys). What's strange is that my PC is connected to the router by LAN cable, and still works. Also, I was able to enter it's configuration page ( Probably some hardware is damaged.

UPDATE (04/16/2011)

NOW I´m confused. I connected to my router with an old low-grade tablet I forgot I had, with no problems. I'm guessing now that the problem must be some app I installed on my phone.

CONCLUSION (04/16/2011)

I just had to press the router's reset button on the back, and now my phone is connecting. Thanks to all who commented!

  • I presume you did reboot your phone ? – Edelcom Apr 15 '11 at 10:15
  • I couple of times. – lamcro Apr 15 '11 at 14:24

Delete the saved network from the phone, then reboot both the phone and the router and try again. If that doesn't fix it you'll need to test with another network to see if it's a phone issue or not.

  • I'm assuming that your phone isn't your only wifi device on your network. Verify that other devices will connect to your network via wifi, if you haven't yet done so. – somehume Apr 15 '11 at 3:42
  • I don't have another wi-fi enable appliance, but I connected to a nearby hotspot with my Captivate. So I'm guessing there is a problem with the router itself. The strange thing is my PC is connected to it by cable and works. – lamcro Apr 15 '11 at 14:24
  • @lamcro That just means it's probably a problem with the broadcasting hardware, rather than the actual routing. Introducing complexity always means a higher chance of failure. – Matthew Read Apr 15 '11 at 14:50

I have the same problem with my friends Netgear wifi router, but all other wifi networks so far work perfectly, so it could be a compatibility problem with the phone and router. To verify this, i'd suggest the steps that Matthew Read and somehume already mentioned: try other networks and check other devices connected to the troublesome network.


If you can access the web interface of the router see if there are any error codes in a log or on the main page after you log in. Most likely your radio is bad but the rest of the hardware is still good (or at least ok :)). This happened to me with an old router too and confused me for a good while before I found the error codes and searched their meaning. In my case it was time for a new router anyway so I just went and bought a new one - so I'm not sure if there's anyway to fix it, if it is a bad radio.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.