0

I'm trying to use WinSCP to FTP a file out of /data/data (well, it's directory is contained in the /data/data directory, which is the important part). But I get a "Code: 5" error from WinSCP, access denied, that is. I've tried to chmod the file I need. But still no luck. Is there any way to FTP a file out of /data/data?

I know the directory is protected. And I know I can use adbd Insecure to pull a file through adb. But I need to be able to pull the file at any time, without a USB connection. And adb tcpip is only good until a reboot. So adb is out of the question, it seems.

Thanks for any help!

2 Answers 2

1

You could try to find an ftp server app that supports rooted devices to access system folders. If you don't have to use ftp, you could use airdroid, which also has a remote file manager.

Another option (if your device is rooted) would be to symlink the folder so that it's stored on /sdcard, which you can easily access

1
  • Well, I'd really like to figure out the permissions issue. It could cause me trouble down the road. And I don't want to have to FTP files to my computer for everything. Being able to chmod would be really nice. But, if it comes down to it, that's a decent option. Thanks! Sep 26, 2014 at 19:01
0

Turns out it works to just remount the system partition as read-write:

In a shell instance:

su
mount -o remount,rw /system /system

I had read before, somewhere, that this didn't work and caused some people issues. But I tried it as a last-ditch effort. It worked for me, at the very least.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .