1

Unless I select 2G as the "preferred network type", my oneplus one disconnects from the carrier. Not just the data connection, even the phone one.

My operator is I WIND.

It's not a SIM problem, since that same SIM works fine on my old phone, and it's not a "it's not inserted well" problem, since if I select 2G it works.

What can I do to investigate the problem? Is this operator not supported or is the phone defective, or maybe some strange misconfiguration? On the official site they claim it is supported "with limited LTE", but it doesn't work with 3G either, while I obviously assumed it did.

3

Updating to 4.4.4 solved the problem (it came with 4.4.2 installed).

  • Hey, don't forget to accept this as the answer, as other users may have this problem and this will (hopefully) help them. Glad you got it fixed! (Have some +1s) – RossC Sep 25 '14 at 14:44
  • 2
    @RossC sure, but it says I can't accept it in the first two days, quite handy! – o0'. Sep 25 '14 at 14:56
  • I guess that is the risk you (and I) take with semi-community developed software – ollie299792458 Sep 27 '14 at 22:52
1

My OPO works fine with 3g and 4g, have you checked the 4g bands are compatible (there is a list on OPO website, and there should be one on I winds).

Are you sure it is losing connection, not just the signal icon showing a drop when switching between sources.

For 3g have you tried restarting (and would you normally get coverage in the area), if so you could try another sim (a friends on a different network) see if it works, if it doesn't it may be a hardware fault.

If another network works and the network bands say your network should work I would contact your network and if they can't help switch network (which you have the freedom of doing, thanks to buying upfront).

If other networks don't work I would recommend reflashing cm11s, especially the radio.IMG, as that will reset the 3g/4g firmware.

If all else fails, contact One plus.

  • It's really losing the carrier, I also get the warning message "No service" and doesn't ever come back up. – o0'. Sep 24 '14 at 22:59
  • Officially it is supported: "Wind (Partial LTE)" "-- --- (Partial LTE) means 3G is fully supported, and one or more LTE bands is not supported." – o0'. Sep 24 '14 at 23:00
  • Ok, have a go at the other things i ve suggested – ollie299792458 Sep 24 '14 at 23:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.