7

I had the Wikipedia app installed a few weeks ago. It lacked the ability to switch between different languages (link to read the same article in a different language), and it still does. This bothered me a lot since I know more than one language and some articles are much better written in other languages. So I like the ability to easily switch language. This is something that works very good on the mobile versions of Wikipedia (e.g. m.en.wikipedia.org).

Here's a screenshot showing an example.

leibniz

Click on the image for a larger view.

So I uninstalled the Wikipedia app in order to go back to browsing Wikipedia content normally via the Chrome or Firefox Web browser. But now when I do a search with Google, and I see a Wikipedia link in the result, it says "Wikipedia app" underneath it. If I tap on it, it tries to open it in Wikipedia app, and since it is uninstalled now, it brings me to the app page in Play Store.

Is there a way I can disable or disallow this behaviour? I certainly don't approve of it, but I was never asked about it either. I'm not interested in using the Wikipedia app any more. I just want normal Web browsing to be back. Is that too much to ask? I tried re-installing and uninstalling the Wikipedia app two times, it didn't help.

Update


You may have noticed that there is an "Open on wikipedia.org" link further down the page. This will certainly open the article in the browser, instead of insisting on opening in the Wikipedia app. But the problem with this is that it's much harder to pin-point the link, because it has smaller font size.

As for "Default applications" menu option, I don't have any option to disable Wikipedia or wiki links. I only have "Home", and "Message" options.

default applications

Update 2


The problem is with Chrome

This problem is clearly related to Chrome browser only. Here are two screenshots of Chrome and Firefox respectively, showing the same Google search results.

firefox chrome

Firefox on the left, Chrome on the right.

Firefox (version 32.0.3) clearly doesn't even have the ability to link to the Wikipedia app. Instead, it would show the article as a normal web page. Regardless of whether or not the Wikipedia app is installed or not.

There are no default options

As can be seen from the screenshot above, in first update, the "Default applications" option has no options to set or reset defaults for wiki links (or other types of app links in Chrome). Additionally, there are no default settings that can be reset under Application manager. Not for Chrome, nor for Wikipedia app. It just says "no defaults set".

chromeNoDefaults wikipediaNoDefaults

Chrome on the left, Wikipedia on the right.

Latest Chrome update solves the problem

Chrome version 33.0.1750.517 came with the latest Android 4.4.2 (or a few versions below that, for this phone model anyway). In this version, tapping on a link for a Wikipedia article redirects to the Wikipedia app automatically. If the Wikipedia app is not present, it brings up the app page in Play Store. This behavior can't be change through setting in the Chrome browser or some default settings in the phone menu. However, updating Chrome to the latest version, which at the moment is 37.0.2062.117 does away with this problem. The first noticeable difference is that it presents the "Complete action using" dialog, which was not present with version 33.x.

chrome-33 chrome-37 wikipedia-2.0

Chrome 33 on the left, Chrome 37 in the middle, Wikipedia 2.0-r-2014-08-13 on the right.

The second difference is what's really good! When you uninstall Wikipedia, it no longer shows the "Complete action" dialog. Neither does it bring up the app page in Play Store. Instead, it opens the Wikipedia article like a normal web page. The normal behavior one would expect. Yes, it still says "Wikipedia app" underneath the link, but it opens like a normal web page. The same behavior as seen in Firefox.

  • I have installed the Wikipedia app again, and the Google Search results appear as normal in it. In other words, the links to Wikipedia articles don't link to the Wikipedia app. Not even when the Wikipedia app is in fact installed! So this is definitely just Chrome browser goofing about. – Samir Sep 25 '14 at 12:23
  • Update 2! There you have it folks. This issue has been resolved through updates of the Chrome browser. – Samir Sep 25 '14 at 18:46
  • Note that there is no option in Chrome settings to disable linking or opening web content in other installed apps. This is by design. The idea is to create seamless transitions from Chrome to other apps for better user experience. – Samir Sep 25 '14 at 21:13
  • Several new (March 2016) "answers" show that the problem appeared in a new form recently. I tried to summarize it in a new question: android.stackexchange.com/q/139489/126176 – Harald Mar 12 '16 at 18:32
4

This is in part because the Wikipedia app is set as the default app for Wikipedia links, and in part because Chrome is not up to date.

  1. Go to Settings menu.
  2. Tap "More".
  3. Tap "Application manager".
  4. If the Wikipedia app is installed, go to step 4. Else, go to step 7.
  5. Locate "Wikipedia" and tap on it.
  6. Under "Launch by default", tap the "Clear defaults" button.
  7. Go back to Application manager.
  8. Locate "Chrome" and tap on it.
  9. If Chrome version number is equal or greater than 37.0.2062.117, press the home button to go back to the home screen. Else, go to Play Store, locate "Chrome" and make sure to get the latest update.
  10. Open Chrome. The following steps are optional.
  11. Press the Menu button on the phone.
  12. Tap on "Settings".
  13. Tap on "Content settings".
  14. Tap on "Website settings".
  15. Locate "en.m.wikipedia.org" and tap on it.
  16. Tap "Clear stored data".
  17. Press the home button to go back to the home screen.

These steps apply to Android 4.4.2.

wikipedia-app chrome-website-settings chrome-website-settings

  • That sounds about right. But unfortunately, I don't have that option. I do have "Default applications" option in the menu. But in there, I only have "Home" (set to TouchWiz home) and "Message" (set to Messages). That's it. No option for Wikipedia links or app. – Samir Sep 25 '14 at 11:59
  • It's not clear from this answer WHAT defaults. It will possibly be the Chrome in your case, since you don't seem to use the Google Search app, go to Settings > More > Application manager > Chrome and clear defaults, HOWEVER, this will clear ALL defaults (so you'll have to reset them for youtube, imdb or whatever apps you have installed) – RossC Sep 25 '14 at 14:03
  • @RossC It says "No defaults set". So there's nothing to clear, the button "Clear defaults" is grayed out for Chrome. What then? – Samir Sep 25 '14 at 17:20
  • @RossC No, I was not using Google Search app (I have it installed though). I used Chrome omnibar to do the search. – Samir Sep 25 '14 at 17:42
  • Instead of posting my own answer, I will take the freedom to update your answer to better address this question. I hope you don't mind. You were on the right track with this issue from the beginning. So I want to give credit to you. – Samir Sep 25 '14 at 20:08
-1

Follow this workaround: Go to Settings → Applications → Internet → change the default search engine to Bing. Bing will not automatically redirect you to Google Play and it opens the page in browser.

protected by Community Mar 12 '16 at 17:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.