I was using ES Explorer to connect to a PC okay but recently I changed the modem then my Android phone can't connect to the computer anymore. I thought it would be caused by a setting on my modem, but searching on Google cannot help me find out. Please tell me how to get my android connected to the PC so I can access files again.

I have ES Explorer 3 on Android.
My Android is connected to the internet through the same modem as my PC.
The D partition has been shared as "Everyone to view.
When I add a new server from ES File Explorer, it says "Error, Can not find the server"
Update: I have turned off Windows Firewall.

16 Answers 16


I had the same problem after updating Windows 10. This is what I did to fix it:

  1. Select the LAN connection of the Win10 PC (under Network tab in ES Explorer. If you deleted it, scan again to get the connection).
  2. Select "Edit Server" option.
  3. Enter your Computer name in the "Domain" textbox. Don't change any other thing.
  4. OK, and enjoy the SMB re-connection!!
  • Thx, this did the trick for me on win 10 with outlook account, though I don't really understand why. Commented Jul 11, 2016 at 18:35

Windows 10 by default disables SMBv1. So, go to "Turn Windows features on or off" > enable SMB 1.0/CIFS File Sharing Support. Now Restart your PC.


I had the same problem. It was with the router. The router was DLink Dsl 2750 u. In wireless basic settings > enable multiAP isolation. That was enabled, I disabled it and I was able to access my pc. Check it if multiAP/multicast isolation is enabled on your router. If it is disable it.

  • This worked like a charm for me since I have DLink router. Nothing was working until now and I had spent weeks. I just disabled multiAP isolation which, I figured out, prevents mobile devices connected to AP from communicating directly with each other. Problem solved. Commented Mar 4, 2018 at 10:58

I have just found out the answer after visiting here. Instead of inputting, we must input smb://

  • However, I tested a SMB connection without this prefix in version 4.1.6 and it worked so this appears to be no longer needed.
    – Edward
    Commented Sep 30, 2017 at 16:51

I tried the solutions mentioned above and in the linked thread. None of them worked.

What did work was disabling password protected sharing. This works on Windows Vista, Windows 7, Windows 8.1 and Windows 10

  1. Go to network and sharing center
  2. Change advanced sharing settings
  3. All networks (at the bottom)
  4. Turn off password protected sharing

At that point I was able to use the ES file explorer scan option to detect the machine. It should show up as grey. Now edit it and enter your Windows 10 account information and you are good to go.


Here's a summary of some important LAN (SMB) connection options to check and edit
(using the ES File Explorer "Edit Server" option of a selected connection in the Network tab):

  1. The "Domain" option - try putting the computer/server name in this textbox.
    On Windows, I think this is the first part of the full user account name (separated by "/").
    On Unix/Linux (Samba file servers), this is the setting called "workgroup/NT-domain name".
    (from the answer at https://android.stackexchange.com/a/150598/239104)
  2. The "Server" option - before the IP address, try adding smb:// (the URI protocol scheme). However, I tested a connection without this prefix in version 4.1.6 and it worked so this appears to be no longer needed.
    (from the answer at https://android.stackexchange.com/a/83428/239104, information originally from https://superuser.com/questions/605452/connect-from-android-es-file-explorer-to-windows-7-share)
  3. Old/new Windows password, username (check with the whoami command), sharing permissions/configuration file on the Windows computer/Linux Samba share (e.g. password protected sharing), network router options, network connections.

If they don't work, try switching the WiFi/wireless off on the Android device then reconnecting, checking the server/computer is connected to the network/internet (hostname -I on Unix/Linux) or restarting the Android device.

Alternatively, if you're trying to connect to a server that has a SSH (Secure Shell) service (port 22), you can use SFTP (SSH File Transfer Protocol) to access files with a user account on the server.
This connection type is available in ES File Explorer - just use the "Network" tab "New" button.


Type whoami in command prompt, it will retrieve the full username of your computer.

Copy the part after backslash and keep it somewhere ready. Type ipconfig in command prompt again and find out what is the IP address of your windows machine.

  • Usually it shows as this "Ethernet adapter Ethernet: IPv4 Address. . . . . . . . . . . :

  • Copy it and keep it somewhere. Now take your windows machine's password as well and keep it somewhere.

  • Go to Windows explorer, and type the following address in the address bar, and press enter "Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings"

  • In Private Network section, select these "turn on network discovery and its subordinate checkbox", "turn on file and printer sharing", then again use this address in windows explorer "Control Panel\All Control Panel Items\Network and Sharing Center" and make sure your ethernet adapter is a private network.

  • Now go to android, open your local network app (in this case es explorer, but this works for other apps as well), use the copied ip address in the host name/ip address textbox, use the copied username and password, and press connect.

  • It will instantly connect to your windows PC where you will see all the shared folders.


In my case, there was a bug with the password. I recently changed the password of my Microsoft Account (which I used to log in to my PC) so I was trying to use my new password in ES Explorer. However, the password that worked was my old password. I guess this is a bug where Windows doesn't update the password used for remote connections and file sharing.


I have got this from time to time, e.g. after the computer has reloaded with a different IP or if I have changed the computer name. When it occurs I usually delete the server from the app, unload ES File Explorer completely, and restart my phone and/or tablet, then when it comes up I re-scan and it seems to be OK again. I have never had to add 'smb://' to the IP, or change from Anonymous, to fix the problem.


I have a laptop with non updated Windows 10 - sharing is no problem with passwords

My computer updated to latest Windows 10 version is showing in ES File Explorer.

But received error: "Error, Can not find the server" with password protection on Windows 10.

Tried the tricks mentioned here but no luck.

Only thing that works is to;

  1. Turned off password-protected sharing

  2. Tick the Anonymous box in ES File Explorer

This temporarily allowed access to public folders but not access other folders that are displayed!!

And this access to public folders was only temporary (once off) now only displays the shared folders but cannot open any of them!!!


I have solved my problem by 'changing PC name'

recently I have changde my PC name and write it in small letters, so write in Capital letters after much struggle I found solution by changing PC name,

If you change your PC name then try this solution under my computer → properties → advance system setting → in computer name tab find change in bottom write with capital letters


Those who didn't set a user password for your PC: You will have errors connecting to server (to your PC) if you leave the password blank. Set up your account password in your PC then use that to connect.

  • 1
    Just saying, I didn't set up a password on my Windows PC, but I could see the shared folder from ES Explorer.
    – Andrew T.
    Commented Nov 20, 2015 at 3:15

So, the only way I got this working was to turn off password protected sharing. Then on es file explorer press and hold on my laptops icon in the network search then click the pencil at the top right then in domain entered the name of my laptop then entered my username and password and then that was it. I was able to see all my files but I cant get into the c drive only my files in my user folder are accessible and obviously public folders. So even turning off the password sharing it still seems secure.

Hope that helps.


On Windows Vista:

In Network and Sharing Center there's a button for Media Sharing. I clicked on the drop down arrow and got an option of Change. On the next screen were permissions. Share My Media To Other users of the PC was not ticked, so I ticked it.

This solved the problem in my case


Instead of using the full e-mail address of your Microsoft account, just use the first five characters. I'm not sure if that's how it generates the username, but you can check what it exactly is by typing 'whoami' in command prompt, and your username will appear after the slash for the domain.


In my case ES File Explorer was not listing my PC under LAN Connections. I solved it by disabling Enable Wireless Isolation under Basic Wireless Settings of my Router's Settings Page.

Follow this if your PC is not listed under LAN Connections in ES File Explorer.

  • Open your Router's Settings page in browser. To do that enter your router's IPv4 Address in Address bar. To Find Router's IP Address run "ipconfig" on your Command prompt. Find IP Address adjacent to Default Gateway (IP format would be 192.xxx.x.x).

  • Login to your Router's settings. If it is public Wifi and you don't know the password, ask the authorities.

  • Go Wireless Settings -> Basic Wireless Settings (Options might differ for different routers, mine was Digisol Router). If your Options are different go to Settings similar to Basic Wireless Settings.

  • Once you are in Basic Wireless Settings Find Enable Wireless Isolation or enable multiAP isolation and disable it.

  • After disabling check in your ES File Explorer whether your PC is listed under LAN connections. It must be listed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .