1

I have a Samsung S3 GT-i9300 which has an error on booting up. It goes through the Samsung splash screen then displays the following:

Device Memory Damaged

The data partition has been corrupted. You need to reset your device to factory defaults. This will erase all your data.

I really don't want to delete the data and am looking to recover the media from the device. I'm not bothered about getting the phone working again really.

I can boot into download (ODIN) mode, but this doesnt really assist (or does it?). I can also boot into recovery mode but I get the following errors also:

E:failed to mount /data (Invalid argument) 
can't mount '/data'(Invalid argument) 
E:failed to mount /data (Invalid argument) 
E:Can't mount /data/log/recovery_log.txt

The device shows in Nautilus on my Ubuntu system but fails to mount. I can select the option to 'Apply update from ADB' and running adb devices shows as:

$ ./adb devices 
List of devices attached 
4df74280146d3071    sideload

Is this of any use to me? Is there a way I can get into the storage to salvage what's there. Can I load a custom rom without deleting everything, or if I do delete everything is there a way to recover the deleted files?

2 Answers 2

2

You could get the same version of your operating system as flashable zip-file for the recovery mode and flash it, or use Odin to flash a kdz-file of it. If the files you'd like to get back are not in the system folder (like music or images) there is a chance they will still be there with the flashed system. Just don't do any formatting prior to flashing!

0
-4

What worked for me was to restart the phone and the damaged message went away!

1
  • Restart won't help much if the device isn't booting up, as the OP indicates. He's obviously tried that already.
    – Izzy
    Commented Dec 29, 2014 at 14:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .