1

My friend gave me his old rooted Galaxy S running android 4.0.x (or 4.1.x probably) asking me to restore its official ROM on it.

Context

  1. Downloaded and installed Odin
  2. Downloaded Galaxy S stock ROM
  3. Downloaded and installed Samsung USB drivers
  4. Removed SIM and MicroSD cards from phone
  5. Cleared cache and data
  6. Put the phone in download mode using the Vol down/up + Home + Power key and connected it to PC
    Although the phone had "Download" option in it's "shut down popup" (The phone was already rooted and had some sort of recovery installed, CWM probably?) but Odin won't recognize the phone while in _that_ download mode.
  7. Flashed the ROM having only "Auto Reboot" and "F. Reset time" options checked
  8. It apparently went OK, phone rebooted a couple times and finally I could see the OS configuration screen

The problem

  • Right after I started configuring the phone, a "com.android.acore" (or similar) error appeared which I "force closed".
  • I restarted the phone (just for a fresh start in configuration)
  • After the phone started I got "com.android.phone" error which I force closed.
  • At this point I felt that something was wrong with the phone, so I turned the phone off with intentions of clearing the cache
  • Then I booted into recovery (Vol up/down + Home + Power), navigated to "wipe cache..." option and pressed OK, but noting would happen. No matter what key I pressed, it was not the "OK" key.

Now

  1. The phone only starts in recovery mode, no matter if I press power button alone or any key combination
  2. There is no key that performs the "OK" function in recovery mode
  3. I cannot reflash the stock ROM because Odin requires the phone to be in download mode (but my phone only starts in recovery mode)
  4. If i connect the phone (running in recovery mode) with my PC, windows displays two removable devices in "My Computer" which show "please insert disk.." error on double click

It is a kind of deadlock situation which I've been unable to resolve. I would like to get to the bottom of this issue

Questions

  1. What is this problem called in android dev. circles? (soft bricked?)
  2. How can I resolve the problem?
  3. Are there ways other than Odin to flash a ROM on Samsung Galaxy S?

I've tried to search through xda and other famous android forums but all solutions to similar problems I could find require the phone to be in download mode.

Any help would be greatly appreciated.

P.S. I'm not a regular android rooting guy so I'm not versed in its jargon but I can read instructions and am waiting anxiously for help.

1

Step 7: Don't have auto-reboot checked. (unless it says otherwise somewhere that I'm not aware of)

Can you get into download mode with power + volume down ?

power + volume up should go to recovery and if there is no OS to boot it likely defaults to recovery.

If you can get into download mode, try finding a different compatible recovery like TWRP. I find it preferable to CWM personally. There is an ODIN flashable file: http://teamw.in/project/twrp2/117 (I'm not sure if this is the exact right recovery - definitely verify yourself) If you can provide additional model details, I can help narrow it down. The worst that will happen if it isn't the correct recovery is that flashing roms will not work and you will have to find a working one and reflash with ODIN.

  1. The soft-bricked term applies to a wide range of conditions but yes this does fall under that category since you cannot actually use your device as intended.
  2. There's several ways to resolve this problem. First try some of what I mentioned already.
  3. You should be able to flash new roms with TWRP. In your state, I would highly advise trying it as you have nothing to lose. (I'm not a fan of Samsung/ODIN myself but have worked with them before. While I can personally confirm that backup/restore works in TWRP, I can only say I would be very surprised to hear that installing a custom rom does not. That is to say that TWRP absolutely should by all accounts work just fine for installing custom roms on Samsung devices yet I have not personally done this.)
  • thanks for the answer. I will try to apply your suggested methods and will get back to you. – Ejaz Oct 9 '14 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.