1

I installed Disable Location Consent and have been having GPS issues where I cannot actually use High Accuracy mode so I removed this module but the problem still remains. Are there remnants of the modules modifications somewhere? How can I find them? I've already tried wiping Dalvik, Data, and Cache.

  • Have you check the xposed module forum site on XDA? Did you deactivate the module before you removed the module? – HasH_BrowN Sep 30 '14 at 16:40
  • yes. i also tried reinstalling to deactivate again and still no luck. – Enigma Sep 30 '14 at 16:48
  • Did you read through - forum.xda-developers.com/xposed/modules/… – HasH_BrowN Sep 30 '14 at 20:45
  • Did you soft reboot after reinstalling module? Then again after activating the module? – HasH_BrowN Sep 30 '14 at 21:16
  • 1
    This is starting to sound like your gps.conf file got borked, which is why i was asking if you added anything else. I have used this ( forum.xda-developers.com/showthread.php?t=1239713 ) as a fix for bad gps.conf before on a couple of my devices. Read thoroughly, then make a backup, then try. If this fixes your problem, i will post as a answer. Let me know. – HasH_BrowN Oct 1 '14 at 14:19
1

I had a similar problem where my SMS wouldn't send to my contacts. That day I had made a few modifications one included a Xposed module, I uninstalled the module and other modifications, but the problem persisted I resorted to restoring an old backup of my phone and the problem went away. I assume as our using a Xposed module your phone is rooted try restoring to a previous backup, it's always good practice to back up your phone before attempting any modifications. If you don't have a backup, then I'd suggest the only option is to restore your phone using Odin (If your using stock ROM) or to Flash a custom ROM

1

Very often happens something strange: if you activate the effect of a module and then you remove the module, then the effect will still be there.
It's the same way of acting as Freedom (for example).
Try installing again the module, deactivating the effect and uninstalling again.
This should work. Tell me if it works :)

  • Did not work. Something still remains in the way of GPS functioning properly. – Enigma Sep 30 '14 at 17:46
0

The other answers are more useful for the question but unfortunately in my case the problem was something different.

It just so happens that the pioneer radio I have has a GPS that I didn't bother installing because I didn't want to use it however the phone is attempting to use the pioneers GPS and doesn't fall back to the phones GPS at all.

So if I use the GPS anywhere else (wifi or data) when bluetooth is deactivated, it works just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.