0

I have a chinese allwinner a13 tablet. The firmware it had was really slow and couldn't use Google Apps so I decided to install a custom rom for it. I tried several roms, but only some were close to 100% working. Some had no working wifi, and the ones that did have a working wifi had other problems.

The best one I found was one that didn't have a working wifi, but everything else was super smooth. So I decided to try to fix it's wifi.

I am not good with android. I found a wifi fixer for allwinner a13 tablets, but for Cyanogenmod, and I replaced the files in the installed firmware with the ones from the fixer. Now when I try to open the tablet, it is stuck in the Android screen from the beginning of booting.

The tablet is rooted. Is there any way to access the system folder where I replaced the files from my pc, even if the tablet can't boot?


Updates:

  • the device can still be booted into recovery
  • the ROM I installed is an .img file and was flashed with LiveSuite. LiveSuite doesn't recognize the tablet anymore when it goes in recovery.
  • ADB detects the device when booted into recovery (adb reboot-bootloader worked fine as well)
  • adb shell does not work; obviously shell is part of what got borked by the "broken flash" (adb shell results in a /system/bin/sh' failed: No such file or directory (2))
  • OK, so it's recognized. Check our adb tag-wiki for some starter first. Try adb shell to access the device local system, explore it using cd and ls. You can adb pull stuff from the device, or adb push stuff to it. Most likely you want to adb push file.ext /system/file.ext (replace file.ext with the real file names, and make sure /system is mounted read-write). If that works out, I'll set up a more verbose answer. – Izzy Sep 30 '14 at 14:42
  • Ouch. That means no shell access – that got borked by your broken install. I hope you know some "explicit file names" which should exist, so you could try an adb pull (not sure whether that depends on shell)? Or you could try placing a dummy file, e.g. adb push dummy.txt /data/local/dummy.txt to see whether that works? – Izzy Sep 30 '14 at 15:06
  • should i get some type of response from adb push? created a dummy.txt in the same windows folder where i extracted the adb, then ran the command, didn't give any error or response. is that good? – sorinACHOS Sep 30 '14 at 15:10
  • and if this means it works and i use push, will the existing files on the device be replaced? – sorinACHOS Sep 30 '14 at 15:12
  • If you've got no error, that should be a good sign. And yes, the files either get replaced – or you will get an error if that's not possible. // Btw: I've just started integrating facts from the comments directly into your question. Let's cleanup comments a little to make it easier to read (you could delete your first 3 comments, as they've become obsolete now ;) – Izzy Sep 30 '14 at 15:14
0

If your device at least boots until the adb daemon starts, you have a change. Try connecting it to your computer and check if it is recognized via: adb devices. If yes you can open a shell by typing: adb shell.

If you flashed a recent Android, I think >=4.3, you will run into authorization problems.

Another way can be to boot this device into recovery, if you recovery still works. You can also use adb, but probably running also into authorization problems.

If adb is not working you are probably running into a kernel panic. Without adb it is kind of impossible to access your system partition.

Edit :

So, as you can boot into recovery you should install ADB(take the link provided in Izzy's comment).

As you are willing to change things on the system partition you should keep in mind that the system partition is usually mounted read-only. In order to remount the system partition read-write you can try adb remount. If this does not succeed you can also try: adb shell; mount -o remount,rw /system. After remounting the system partition read-write you are able to "push" files there via adb push and you can open a shell/console/terminal via adb shell .

If you have knowledge about some basic linux shell tools like dd (try man dd on linux or use google) and you know how your partition layout looks like and you also have the old boot.img, system.img etc files you can "dd/flash" them back to your nand flash, which will restore the old ROM. Also there is proprietary flashing software out there for allwinner devices (I think it is called phoenix suite) which is also able to restore ROMs (keep in mind that you need a proprietary flashing file format here).

The above mentioned dd restore should only be done if you know what you are doing as it may destroy more than it repairs.

  • tablet can be booted in recovery. if i just turn it on, it goes to a green screen with the android logo and stays there forever. If i can acces the system partition, i will replace the "replaced" files in system with the original ones from the custom rom. I made a backup of them. – sorinACHOS Sep 30 '14 at 14:06
  • I get some mixed emotions with this post, @divided. Thanks for helping out, the post has useful hints – but this is not a forum; on SE sites, answers are for answers, and we use comments to ask for clarifications (which you currently lack the rep for). So with the new facts provided by the OP, please edit your post and keep it updated, so it at least ends up as an answer ;) Thanks! – Izzy Sep 30 '14 at 14:13
  • Thanks for your update, @divided! Unfortunately, dd and the likes won't be an option, as sorin has no shell access on the device. Same for the other commands relying on that. Mounting still should be possible via recovery menu, though. – Izzy Sep 30 '14 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.