0

After I root my Samsung Galaxy Mega 6.3 (GT-i9205), I downloaded SuperSU from XDA Forums. After I open SuperSU, it asks me to update my su binary.

The SU binary needs to be updated. Continue?

But after a long time, it got stuck on

Installing, please wait. If you see this message for more than five minutes please restart and try again.

Then I tried to check whether my phone is rooted or not by using a root checker. At last, the answer is does not have proper root.

Please help!

1 Answer 1

0

I faced the same problem when I tried rooting a Chinese phone having Samsung Galaxy S2 stock ROM. I searched and here is what I found.

Firstly, try installing binary through BusyBox Installer on Play Store. Internet is required to download and then try every version.

If it didn't work out for you, then download Kingoapp. It's a one-click rooting method. Kingoapp has successfully. In some cases, it will ask you to install custom recovery in order to root your device if it failed to root your device in an ordinary way, so if you don't want to lose your stock recovery, just cancel the rooting procedure.

2
  • I have already tried it but it wont work for me..is there another way?
    – Alexander
    Commented Oct 4, 2014 at 13:01
  • What method did you use to root your phone before installing SuperSU? Finding SuperSU on the launcher drawer without manually installing it is a sign that your phone has been rooted. I forgot to mention that after I root my phone through Kingoapp, I got the same error, so I tapped on updating the binary and it works after reboot. Yes, there's using Odin. Check out this tutorial on Android Central. But please, before you start, do your searches on Google and YouTube for "How to root Galaxy Mega 6.3 i9205". Commented Oct 4, 2014 at 15:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .