After I root my phone, I downloaded Super SU from here and after I press in Super SU, it ask me to update my su binary but after a long time it got stuck on (installing please wait...) then I tried to check whether my phone is rooted or not by using root checker. At last the answer is does not have proper root. Please help!


I faced the same problem when I tried rooting A china phone having Samsung Galaxy S2 stock Rom. I searched and here is what I found Firstly Try installing binary through Busybox installer on play store. Interent is required to download and then try every version if It didn't work out for you. Then Download Kingoapp it's One Click rooting method. Kingoapp has successfully. In some cases it will ask you to install Costum recovery in order to root your device if it failed to root your device in the ordinary way so, if you don't want to lose your stock recovery just cancel rooting procedure.

  • I have already tried it but it wont work for me..is there another way? – Alexander Oct 4 '14 at 13:01

What method you used to root your phone before installing SuperSU?

Finding SuperSU on the launcher drawer without manually installing it is a sign that your phone has been rooted! I forgot to mention that after I root my phone through Kingoapp I got the same error so I tapped on updating the binary and it works after reboot.

Yes there's using Odin, Check out this TUT.


but please before you start do your searches on Google and Youtube for "How to root Galaxy mega 6.3 i9205"

Best of luck. BTW I really like the big screen of this device as I'm an addicted to watch Tv series through phone screen :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.