I bought a new Android One device from Amazon.in but I'm unable to install or update any applications from Google Play Store on it when I'm connected to wifi. The error message is a 489 download error.

I found the problem documented at a few other places on the internet like this but there doesn't seem to be a know solution for this.

I have tried to delete my account and add it again, do a factory reset and try again none of these has helped. If however I switch to 3g I am able to update the apps, but my 3G plan is limited and I like to use it when I'm on the go. I have a pretty decent wifi at home which I want to use for updates and app installs. Living on just 3g is not even an option.

Does anyone know of a fix for this? Since I got the phone from Amazon, they are pretty customer friendly and I should be able to return the phone easily should I do this?

I was able to install Amazon App store and have been successful in installing apps using it over wifi but this isn't a scalable approach for me either as I won't get the android updates and things like Whatsapp seem to be missing from the Amazon App Store.

My hunch is that there is some software issue with Google Play but I don't know if that is the case or if it will be fixed. What is the best thing for me to do in this case?

  • Well, Micromax is having this issue and many users are facing this issue. You can read all the reviews regarding this here.
    – Kunal
    Commented Oct 6, 2014 at 7:03
  • I did check out the review before buying, but these seem to be much lower down the thread. Anyways I have my money back, will gift my parents something else later.
    – nikhil
    Commented Oct 12, 2014 at 10:25

1 Answer 1


Happened to me as well when I first got my Nexus 4, but it was somehow sorted out. It is possible that I "forgot" the WIFI network and then connected to it again but I'm not sure.

Try to see if you can download apps through the web version of the play store: (from your computer, I mean) https://play.google.com/store

This isn't an issue that should get you to return the phone to Amazon, I'm pretty sure it is a software problem.

Solutions that I came across

Solution 1

  1. logging in Google App store using your gmail id in your pc.
  2. Select the App that you want to install.
  3. Click on install .
  4. Make sure at the same time you mobile is connected to wifi. Then App will automatically get downloaded and installed in you mobile.

Solution 2

I not only tried all the above steps I also got my mobile formatted but it didn’t work. More so, I got it replaced. Still not sure what’s the problem – maybe it’s the mobile maybe it’s the google app store. whatever it is, I found a way to use wifi to download from play store. It’s quite simple actually, start downloading using your normal data connection and quickly switch wifi. It will automatically start using wifi to download stuff. Use Go widget for switching if you want to.

I don't know if they will work but it's worth a shot...

  • I'm not the only one who has this error apparently - amazon.in/product-reviews/B00NEFFWF6/… The reason that I'm worrying is that there is not a known solution, even you say that it worked somehow...
    – nikhil
    Commented Oct 5, 2014 at 17:48
  • I may have found solutions for you. I have edited my answer.
    – nettek
    Commented Oct 5, 2014 at 18:02
  • Thanks Eran, but the first solution didn't work and the second one is so severe a hit on the usability that I can't continue with it. I contacted Amazon, they'll issue me a refund. It's frustrating but I got this phone for my parents and don't want to leave them with something which is sub standard, they aren't the most technical people.
    – nikhil
    Commented Oct 6, 2014 at 5:20
  • 1
    No problem, it's just too bad it didn't work for you. If you need recommendations for another phone that is suitable for your parents yet not some high-end phone they don't need, try the Moto G or Moto E.
    – nettek
    Commented Oct 6, 2014 at 6:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .