0

I have over 7GB of internal space left on my phone yet it keeps telling me to delete files and pictures. I deleted all of my pictures and some big apps but it continues to tell me the same thing when I try to take pictures. I have a droid RAZR mini. It has no space to put a SD card in. Unless I can somehow take off the back. Someone help please.

1

There a couple of places that are known to use space up, once you have eliminated all other space hogs.

  • /.thumbnails safely delete them and then you can add an empty file and name it .nomedia and it won't store thumbnails anymore
  • /data/log safely delete log files that accumulate after time
  • /data/tombstones safely delete debugging logs that accumulate after time.

Always perform a backup when deleting or changing anything

1

I managed to fix the issue where I was getting an "Insufficient storage" for my camera app. This was after I 'changed' a MicroSD card in my Moto X Pure. It was driving me a bit batty. But it's fixed.

I downloaded a file explorer (in my case it was ASUS File Manager). I saw that I had a DCIM folder. (Under Internal Storage and navigate to DCIM). I found that I was unable to move any files to this folder or even SEE the folder on my laptop (as you can connect to your phone using the ASUS File Manager via a wireless mirroring connection). So I tried to create a DCIM folder via my laptop. But got a permission denied. So I went back to the phone's file manager and renamed the DCIM folder to DCIMold. I then created another DCIM folder. Yay! That seemed to work. And more excitingly so did my camera app.

So it was the dreaded lack of a DCIM folder. In my case it wasn't because it was missing but rather that it was somehow corrupted and had the wrong permissions. If it was even really there.

If anyone needs a better explanation let me know. I just jotted this down for my reference as I was so excited to get over the latest hurdle on the phone!

0

It would be good to check your internal partitioning.

First of all I would recommend you to install a terminal emulator like: click if you are not used to the Android Debug Bridge(ADB).For detailed information about ADB see: click

Write into this terminal: df and update your question with the output of this comment. Also the output of mount would be great to know.

Hash_BrowN already suggested you to check some places which can use much space. There is an app which you can use for a more intuitive way of checking and clearin these places: SD Maid

  • I didn't recommend that app because of the permissions required. There are other ones that come to mind, but I would find an open sourced one instead. – HasH_BrowN Oct 10 '14 at 1:45
  • It is an app developed by a recognized developer from xda-developers forums. Some pages for privacy: sdmaid.thedarken.eu/privacy and sdmaid.thedarken.eu/privacy/sdmaid_mytransmission.html. If you agree with this anonymous transmission you can use this app and delete it right after cleaning -> Problem solved. :P – divided-by-zero Oct 13 '14 at 7:23
0

The same thing happened to me. If you had an sd card in your phone, but ejected it, then go to settings, go to storage, then there should be the sd card that you ejected. Press forget on the ejected sd card, and the camera should work.

0

None of the solutions here (or elsewhere) worked until I did a very simple thing: I downloaded another camera app from the Play Store. All of them are taking pics normally.

This solved my problem when the camera app started showing error "memory unavailable" after programming the SD card to work as internal memory so I could actually have some space in my phone.

-1

I just came across the same problem on my Moto G 2nd gen and it was caused by swapping SD cards. I had to do a factory reset to get the camera working again - backing up contacts and apps first of course. All good now.

-1

DCIM should be 0755 but I guess remaining it did whatever. More than likely just made a useless folder. Sounds like you have some wacko partition. Maybe open the back with a dime or something and put a cheap SD card in it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.