I'm having out of memory problems with rsync in CYM11. However, I realized now that the problem is more serious. For some files, when I simply try to list one single file with name somefilename in the terminal emulator, I get:

 $ ls somefilename
 ls: somefilename: Cannot allocate memory

If I do ls over the somefilename parent folder (with 30 files only), I see several files but not somefilename.

But then, after a wile, the error is gone...

Clues? Maybe a card problem?



PS: [rant] I'm having too many problems with CYM11! [\rant]

  • My first guess would be a bug in the memory management in the OS. Are you using a nightly? Have you tried a different nightly or a more stable build?
    – Dan Hulme
    Oct 8, 2014 at 10:05
  • I'm honestly at the stage of "CyanogenMod, there's your problem" and the frequency of this is increasing. Maybe another ROM would be an idea, or as Dan said something more stable. (I know they do great work, but I've never tried a build that didn't have something preventing it being a daily driver on ANY device)
    – RossC
    Oct 8, 2014 at 15:17
  • @DanHulme: Yes, I'm using a nightly for the Galaxy Note (n7000). I cannot use a stable build, unless I go back to 10.1.3, since there are no M builds for the N7000. Oct 8, 2014 at 16:14
  • No wonder you're having too many problems then. Nightly builds are not intended for everyday use.
    – Dan Hulme
    Oct 8, 2014 at 16:16
  • @RossC: Indeed, that's my experience too. Unfortunately, I've experienced several problems with Cyanogenmod, and there is very little support (I've never able to get ANY answer from Cyanogenmod website). Not sure if any other ROM is better, though....? Oct 8, 2014 at 16:16

1 Answer 1


Cyanogenmod 11 is extremely buggy on the Galaxy Note I (N7000), and this seems to be one more of its bugs. I solved it by reformatting the card to ext4 (reformatting to exfat didn't solve the problem).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .