0

i have an Samsung Galaxy S4 LTE (i9505) with stock rom + root (4.2.2 ME2 build).

i have issues from time to time with Bluetooth pairing. It stopped working a few months ago, then started working again by itself, then last month stopped working again.

When is not working , i have this issue when i try to pair a new device (the problem is with devices that have PIN code, the one without, pairs successfully) : it shows the 'Enter PIN' dialog, but when i finish it doesn't start pairing, it does nothing.

I attach a video to understand the problem, also a Verbose Logcat (logged when this issue happens)

It would be great if somebody finds the problem in the log, because if i can fix it without restoring/changing ROM would be great!

  • what kind(s) of device are you trying to pair it with? – Dan Hulme Oct 16 '14 at 10:08
  • doesn't work with any device that has PIN for pairing , either Carkit or headset or other Phone, etc, i tried on 10 devices, as you can see in the video, the problem is the phone software, after you enter PIN and press OK, it doesn't do pairing, it does nothing... it should said Pairing... if it was working, it's a bug somewhere and i cannot find it, that's why i posted the Logcat, maybe someone with more Android experience would find it... now it has the same behavior like when you press Cancel on entering PIN – George Dima Oct 16 '14 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.