0

I've updated the ContactsProvider.apk file in sys/priv-app. However, I'm trying to flash the latest CM update and I keep running into a hash miss-match. In specific:

assert failed: apply_patch_check("/system/priv-app/ContactsProvider.apk", "fb6e94a195230a7d056372699dfe01a7ad7cefad", "4be1a92ade982716f9f64e53a48bdbb6dad997a")

With this, I'm unable to complete the flash through TWRP. I'm on the latest img (v2.8.0.1) and have already tried restoring to an earlier backup to see if the file would go back to its original state. When I restore, everything goes back (as expected) but the file in question does not. I've also tried to adb sideload the update and that wasn't successful either.

I'm looking for suggestions that might help me get passed this, even if it means a full wipe or reset.

1 Answer 1

1

The error is telling you that it won't apply because the system you currently have doesn't match the base that the update is meant to apply to, because you've updated this file. Don't keep trying to apply the update: if you can somehow circumvent the check and flash the update anyway, the result will be a broken OS.

If you still have the original ContactsProvider.apk file, restoring it will allow the update to apply.

If you can't restore the original ContactsProvider.apk, then you won't be able to apply any further updates. You need to download a complete Cyanogenmod image and flash that. OTA updates will then work again, so long as you don't edit any more OS files.

1
  • Thanks for the advice. I've flashed the version I have currently and it updated all the system files. I then flashed the new bacon snapshot and it worked out. Oct 12, 2014 at 21:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .