I have been messing around with my Archos 7 Home Tablet V1, and have currently installed this ROM.
Now when I go to Settings -> SD card & device storage, Total space under SD card is "Unavailable", and Available space under internal flash storage is 0.00B.

I also cannot browse through the internal or SD card with explorer.
I have tried formatting the SD card on the device, by pressing Format SD card in this menu, but that did not change anything.
Now when I connect it through USB to my computer, Windows 7 tells me that I have to format the INTERNAL memory before I can acess this.

My question is: Can I "safely" (I mean, will it not brick it? I understand if no-one can be sure about that ;) ) do this while the tablet is running, then reset it, and flash it again? Or will I be able to say bye bye to it when I do this?

Also, what is the default filesystem on the internal memory? fat32, fat, or what is it?

Thanks in advance!


2 Answers 2


Alright, on the forum thread of that specific cusom rom (linked in question), someone said that he re-formatted through Windows with FAT32 as type. So I tried this as well.

While the device was on, I plugged in the USB cable, and put it into lock. Then, as usual, the drives showed up in Windows (SD and Internal that is), and it forced me to format the internal drive in order to acess it. Pressed ok, then formatted with FAT32. After format, I did not even pull the device off the lock, I just quickly pressed the reset button on the back. Then flashed it, and turned it on.

It works perfectly! Now I have Android 2.1 instead of that less-worthy 1.5 build!

Thank you to everyone who proceded help :)


I suggest you to format the internal memory since it won't clean the ROM memory, just the place where your personal files, applications and other stuff like this are stored. Then flash the ROM again. This might solve your problem.

  • I don't exactly understand what you mean. I can't acess the internal sorage in any way. Also, do you know what the default filesystem is?
    – user4523
    Commented Apr 20, 2011 at 18:08
  • You can format it without any problem, but after this flash that ROM again Commented Apr 20, 2011 at 22:56
  • You shouldn't format it with Windows though, if that is what you are asking. Do a wipe / factory reset on the device itself, then reflash the ROM. Commented Apr 23, 2011 at 8:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .