0

SPH-L710 Virgin Mobile

Flashed from MOAR to Stock SGS3 ROM

I flashed a ROM and I wanted to get back into recovery mode to flash a zip file using ROM TOOL BOX and when I did that it never turned on again. There's no lights or any sort of life on the phone. I've tried,

  1. Turning the phone off for 30 seconds or more
  2. Holding the power button while battery is removed for over 1 minute
  3. Charging the phone while battery is inserted and pressed the power button
  4. Charging the phone without the battery inserted and pressed the power button
  5. Connecting the phone to my PC with and without the battery. Instead I get a light (red or orange, I can't differentiate the 2) and my computer beeps stating it's connected.

I've read a couple of stuff but it seems like I would have to buy certain things for it. I saw a "Jig" that could help it but I don't think it would work on my phone since it's Virgin Mobile and it's meant for Sprint or buy a Class 10 MicroSD Card.

Any ideas on how I can get it fixed without buying anything? Unless I have no choice...

-Side Note-

If anyone understands this, I think since I flashed d2lte or dlte instead of dspr it gave me this headache.

0

Try holding down the home button, the volume up button and the power button for a few seconds. If that doesn't work, try the volume down button. Vol up will try and boot into recovery, vol down into download mode. Source

  • I tried that too, still no luck – Brian Gomez Oct 28 '14 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.