2

I have a Google account and a MS Exchange account (Outlook). There are multiple instances of hundreds of duplicate contacts for a single name; e.g. John Smith. They are in "not assigned" groups. If i go into contacts and delete all 200-400 of them, they all reappear in a couple of hours.

They take up so much space; there are thousands of them.

I very much appreciate your help and ideas.

I"m using a Galaxy S3, v4.4.2.

  • Reviewing this question, have you been able to answer this question? If my answer suffices please mark it so, if you have the solution please answer your own question of let us know if it is still not solved. – DankyNanky Feb 6 '15 at 8:52
0

Firstly where are the duplicates from? You should be able to selectively sync items from exchange, thus uncheck the contacts section. Furthermore, some default contact apps allow "link", where you can link all aspects of the contacts. I gather your issue is for phone, mobile, email etc it is creating another contact.

The fact that they are reappearing backs the theory it is due to repeated sync. A handy alternative would be grab any contacts from your exchange, tick the option to migrate to SIM then disable sync. You'll still be able to search for them via email etc by selecting "search on server" etc.

0

On my phone this problem appears to be caused by LinkedIn. Try disabling that sync and then clean again. It only happens to certain contacts for me.

0

You can manage duplicate items in Google contacts. For that your phone contacts need to be synced with google contacts. After the sync you need to visit Google Contacts Preview website to find/manage the duplicates. You'll be able to see on the left side of the screen that an option to "Find duplicates" avaliable. Just click on that and google will manage to find and arrange the duplicates for you. You can merge all the duplicates into one contact by clicking "Merge All" button at the top. Now that it is a single contact you can either wish to keep the contact or delete the merged contact. This way you merge all the duplicates and delete them at a single click. ;)

Note: If you don't have any duplicate contacts in contacts.google.com then you'll see "Yay! No duplicates found." which means you are having no duplicate messages. Before mergin contacts see if they are duplicates by checking the phone number or the contact name sometimes

0

I had a similar problem a few minutes ago. I had literally hundreds of duplicates for two of my contacts. When I selected any of them, nothing opened except for a tiny message saying "The contact doesn't exist." I couldn't erase them.

I read this: http://www.anushand.com/2015/04/my-nexus-5-couldn-connect-calls-with-my.html and tried what they suggested (uncheking the contact syncing boxes of all accounts from the Accounts section in the Settings), but it did not work.

What I had to do is go to the Outlook app and THERE uncheck the contact syncinc box. Now everything seems to work fine, all the duplicates are gone.

I'm not sure if I had to uncheck both boxes, the one from the Accounts section in the Settings AND the one directly from the app, in order for this to work. Maybe only one of them is buggy.

Anyways, right now I'm not taking chances: I'm only syncing Google contacts.

I have a Nexus 4, 5.1.1.

Cheers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.