1

When I download anything over 70 mb onto my phone, the download gets about ~95% then it stops and a pop up saying something along the lines of, this app cannot be downloaded due to error (911) appears.

Does anyone know how I can fix this?

3

I have never encountered this specific error before, but you can find it among a list of common Play Store errors compiled by enthusiasts* on XDA.

They have 4 recommendations for the 911 error:

  • Method 1: Clear the google play store data

  • Method 2: If you are using a wifi connection that requires a webpage login, then your authentication has probably expired. Log in to the apn again via your android browser. Open google play store and run the app update again . If that didn’t work the problem is with the wifi network itself.

  • Method 3: Simply switch to another wifi network and run the update. The error 911 should disappear for the new wifi network.

  • Method 4: Use your mobile network data services instead of wifi. Turn wifi off and then turn your data on and now open your google play store and download/update your apps or games. However, this method is only suited for apps and games that are small sized. For larger updates you should use your wifi network to save data charge.

*Keep in mind that this list of errors and recommendations is not endorsed by Google, and may or may not be valid in your situation.

*This list is taken verbatim from the linked site, all credit goes to the list of users quoted on top of the linked page for compiling the list

0

I have had this same issue before with the Sim City Buildit game/app. I run android 4.1.2 on a rooted LG Optimus f3 (vm720). In my case, none of the standard solutions (as was posted by Raghd Hamzeh) have ever fixed any problems with my phone, but they do work for some.

I'm still not sure exactly why it errors at the 95%, but it appears as if it downloaded the entire OBB file without finishing the task completely. I only noticed this because the "disk space is limited" notification popped up. I check the data folder, and there are about 7 different OBB files all named temp.appname.whatever (with a corresponding number following it as they're all duplicated files). So in my case, I just deleted the excess temp obbs, renamed "temp." away from the downloaded obb, and it worked immediately after - allowing me to download the new APK without a problem.

0

It worked for my Asus Zenfone V live (A009) I don't know if it works for other phones but I clear up as much space as possible on the internal storage and it works everytime. Don't use a junk cleaner though, they don't help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.