0

I was re-flashing the firmware on a Samsung Galaxy S4 using Odin, and the USB cable was bumped, which made the update fail. I reconnected and attempted to flash again by clicking the Start button. It seemed to be progressing, but Odin's blue progress bar continued from where it had stopped instead of starting from the beginning. After a while I got the following warning message from Odin, in red text and repeated 19 times:

Invalid percent of drawing download progress bar!

followed by this at the end:

SECURE CHECK FAIL : system

I attempted to start the process again (by clicking Start in the Odin desktop app), but it failed multiple times. I also tried clicking Reset and starting again. It doesn't seem to be possible to do anything from within Odin on the phone. It doesn't respond to any buttons and doesn't react in any way when I try to start the process again from the computer (no more messages on the screen, and no movement in the progress bar, or anywhere else). This doesn't necessarily mean it's frozen, though, because I don't believe it's intended to be interactive. The blue progress bar on the phone is all the way to the end, where it has been since my second attempt to flash.

I have not restarted the phone, because I am afraid that if I do that after an incomplete flash, I will not be able to get back into Odin. It is still on, still in Odin, still showing all the errors. The desktop Odin app on the computer can detect when the phone is connected and removed (I get the "Added!" and "Removed!" messages).

Am I correct in my concern that I'm likely to brick the phone if I attempt to restart without flashing successfully? Is there anything I can do to restart the process? It would be an astounding design flaw if Odin really isn't capable of restarting a failed flash to allow for recovery if the process fails and the device has not yet been restarted and Odin is still in RAM.

I know for a fact that the ROM file I'm using is valid and that I'm doing this correctly, because I have gone through this process several times and never encountered a problem until this time when the connection was interrupted. I have no support available from either Samsung or the carrier (Verizon), because I bought this phone used on eBay specifically for experimenting with things like custom recoveries and ROM flashing.

FWIW, here's a screen shot of the Odin desktop app as it is now:

enter image description here

  • I would try to reflash it myself, keep in mind Odin is not a tool for public use, it is a Samsung tool for employees and has been leaked rather than released as a public facing interface. Kies is the official software. It may just do that. Since it started flashing I'd try to reflash, or failing that restore a nandroid backup via recovery. Once you can boot to recovery you can can flash SOMETHING on to the device. It might be worth going to a whatever you can restore (nandroid, custom rom whatever) before trying to restore stock again. – RossC Oct 21 '14 at 14:16
  • @RossC The point is that I'm concerned that if I restart the device after an interrupted flash, it will be bricked and I won't be able to get back into Odin, or recovery, or anything else. I'm not asking in general how to restore the phone if I can successfully restart it (if I knew I could do that, I'd just go back to Odin and reflash); I'm asking if there's anything I can do while I'm still in Odin, before taking the risk of rebooting and seeing if I can get back into Odin or recovery. Kies doesn't recognize the device while it's in Odin mode ("The connected device is not supported..."). – Adi Inbar Oct 21 '14 at 14:56
  • Flash a custom recovery on the device now thorough Odin. Then try to get back to where you were or try the stock ROM again. Otherwise I'm out of ideas. – RossC Oct 21 '14 at 14:57
  • I did try flashing again. See the explanation above. Everything from the second sentence through the end of the second large paragraph describes what happened when I tried to do that. I'd love to be able to flash again now. The question I'm asking is how? Is there a way to force Odin to restart the process without restarting the device? AFAIK Odin may now only exist in RAM; the failed attempt to flash might have destroyed it in the ROM, and I won't know if it's still available unless I risk restarting. I'm looking for a way to get Odin to flash again without restarting first. – Adi Inbar Oct 21 '14 at 15:08
  • BTW, the phone was already soft-bricked, so Odin was the only option (restoring a nandroid backup didn't help; I tried). I was testing out the Online Nandroid Backup app, and when it rebooted it was stuck at the Samsung logo screen. This already happened twice before and both times I fixed it by re-flashing the stock firmware with Odin, then restoring the nandroid backup. – Adi Inbar Oct 21 '14 at 15:10
2

After waiting a couple of days and not finding any answers, I restarted the device. It booted to a screen saying

Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again.

enter image description here

I tried using recovery mode in Kies, but Kies gave me an error message saying that the device is not supported. However, I noticed that the text in the upper left corner of the screen indicated that the phone was in Odin mode (showing the above message instead of the usual Downloading...do not turn off target!!!). So, I launched the Odin desktop app and tried flashing the firmware again, and that worked.

Basically, I was lucky. In some cases if a ROM flash fails, you can't get back into Odin mode. So, I'm posting this in case it helps someone, but I'm not going to mark this as the accepted answer, because I'd like to see if anyone has a solution that avoid taking the risk of restarting and hoping for the best.

  • Usually, a failed flash is irrecoverable if it gets interrupted somewhere around flashing sboot*. You can mess up everywhere except any of the sboot files. If you did, hopefully you have a JTAG box laying around. – PNDA Mar 28 '17 at 12:36
  • You can mess up literally anywhere. As an experiment, try flashing TWRP via Odin, but unplug it while flashing. Try going into recovery. It won't work. Flash it again, letting it complete this time, will fix it. – PNDA Mar 28 '17 at 12:39
1

As far as I understood your flash process interrupted and normally you are afraid to restart the device but the key point in here is you dont change "download mode" with flash process. Dont be afraid.

Feel free to close the device and reopen download mode with Volume Down + Home + Power, Use ODIN properly this time.

protected by Community Aug 31 '15 at 13:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.