I have cynogenmod7 on my optimus one phone. I followed this guide to run debian on it. When I give this command:

busybox mount -o loop,noatime $kit/debian.img $mnt

I get a no loop device, file doesn’t exist error. I tried setting up more loop devises like loop1, loop2 so on, even tried loop99 but still I got the same error. Is there any work-around this issue?

1 Answer 1


Make sure you follow the tutorial exactly unless you know what you're doing (well, unless you know what you're doing, you shouldn't be attempting to install foreign system, like Debian, over Android; the tutorial said it clearly: If you are following this tutorial only because you want to /flex on your friends and you don't know anything about linux, then you really _should_ stop reading this tutorial.).

Make sure that the shell variables $kit and $mnt are defined and have the appropriate values (if you follow the tutorial correctly, then $kit should have the value /system/sd and $mnt should have the value /data/local/mnt).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .