3

I recently got my new OnePlus One and it worked fine. Today I unlocked it and noticed that it rebooted because I needed to enter my PIN code (it crashed).

After I entered the pin code I got some warnings about the missing play services. All the apps were gone to, accept for the default ones.

As you can see in the screenshots, I can't login to any application that uses the google services. It prompts me with the option "Get Google Play Services" but when I click that, it redirects me to the Play store were I need to login... Because of this I can't reinstall the play services using the Play Store application. I also tried to install it from my computer but my google account says it's already installed.

Is there a way to reinstall the play services without doing a hard reset?

Error after rebooting, can't login using my google account screenshot
Screenshots (click images for larger variants)

2

I would sideload the play services app.

You can download it from here, no play store needed

http://forum.xda-developers.com/android/apps-games/app-google-play-services-t2795911

Just download it to your PC then transfer to your device via USB.

  • 1
    tried this, but in the end, a hard reset was the only thing that solved everything – Frederik Voordeckers Nov 20 '14 at 18:51
0

Google gaaps or goo.im you might have to reinstall them using your pc. If you don't have it yet you might need terminal emulator. Also I'd suggest ROM toolbox pro. Any modded android should have those two apps.

  • Thanks, but its not really a modded Android, Cyangenmod is installed by default on OnePlus devices. And I can't install new apps using the Play Store, also on my computer. I can't log in to my Google account anymore so my device won't notice when I command it to install an application via my Play Store account. – Frederik Voordeckers Oct 21 '14 at 19:03
0

Search 1Mobile Market and download it directly to your Android device or from your pc and install that. In the app look up and download Google Play Services. Note your device should be rooted.

  • Why should the original asker have to do this? The 1+1 has google play services. It is a google experience enabled device. A better solution would probably be to remove data and updates for Google Play Services and Google Play. That will remove any updates to the services and play store, and then they should be able to log in again. – Ryan Conrad Feb 23 '15 at 21:43
0

I'm not positive if it's related but I was getting this message consistently with Gmail and I wound up uninstalling a free app I downloaded the other day. It was some vibration meter software that records data and stuff. I hit this email data log feature and it triggered an in app purchase that I declined but I think it messed with the email somehow.

After uninstalling I was fine.

protected by Community Feb 26 '15 at 18:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.