4

I realise this is asked countless times but I genuinely believe my question is unique, please bare with me as I explain.

My Nexus7 (2013) is not working in fastboot mode, I connect my Nexus 7 and run the following:

$ adb devices
List of devices attached 
07c15663    device

The Nexus 7 appears (once authorising adb), so I then reboot to fastboot (or bootloader):

$ adb reboot bootloader

The Nexus 7 reboots into fastboot correctly and I see the usual screen:

Nexus 7 in fastboot mode
Nexus 7 in fastboot mode (click image for larger variant)

However, when I issue any fastboot commands it cannot see the device:

$ sudo ./fastboot devices
[empty response]

...and lsusb doesn't see the USB Connection:

$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 5986:0266 Acer, Inc 
Bus 001 Device 005: ID 0a5c:21e6 Broadcom Corp. BCM20702 Bluetooth 4.0 [ThinkPad]
Bus 001 Device 004: ID 147e:2020 Upek TouchChip Fingerprint Coprocessor (WBF     advanced mode)
Bus 001 Device 035: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for     Bluetooth
Bus 001 Device 034: ID 046d:c049 Logitech, Inc. G5 Laser Mouse
Bus 001 Device 032: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 031: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 030: ID 0bdb:1926 Ericsson Business Mobile Networks BV 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

to add to this weirdness, once it's booted up properly the Nexus 7 appears as a Nexus 4 in lsusb:

$ lsusb
[...]
Bus 001 Device 060: ID 18d1:4ee2 Google Inc. Nexus 4 (debug)
[...]

I'm so confused, what have I done to my poor Nexus 7?? Please Help!

Also:

  • The device seems to freeze after extended periods in fastboot at which point the only solution is to push and hold the power button for 10secs (hard power off).
  • I can use fastboot with my Nexus 4 without any problems
1

Have you tried putting the proper drivers in the right locations on your filesystem? This has been an issue with my Nexus 7 as well, and was solved by acquiring the proper drivers.

Also, it seems from your fastboot screen information your Nexus is fairly custom at this point (product name usually reads grouper, the device codename, yours seems to call itself FLO?). This may affect what drivers are required, but I am not an expert in driver compatibility. Perhaps, due to the ambiguity of what can be flashed to the fully unlocked Nexus line, you may actually have pushed Nexus 4 firmware to your device, and due to the fact that they differ only in size, it may appear to you to still be running the software for the 7.

It appears your device has, in the fastboot information, a slot for reading to the user what carrier the device is currently subscribed to. This should, to the best of my knowledge, only appear on the Nexus 4, or the GSM capable 3G enabled version of the Grouper (Nexus 7). It can be very easy to push the files for your phone to your tablet accidentally, and might be worth consideration.

If you have a WiFi only device, this is likely the issue. A quick way to discern if you have the Nexus 4 software on your Nexus 7 is to run an application that has a user interface which is programmed to change from the phone to the tablet (a list of such apps should be easily found with a Google query. I believe Gmail is one, but that may be blurry for us with the Nexus 7 because it is considered a "Phablet", a hybrid style device).

I recommend trying to erase all Android drivers on the host computer, and reinstalling the specific drivers for the Nexus 7 only, then after hopefully solving the issue, redownload the other necessary drivers for other devices, only after this issue has been resolved.

If that is not helpful, I would consider a full overhaul of your system through pushing a Google supplied system image through adb, and using recovery partition to erase everything and reinstall stock flavor of this device. It may also be possible fully through adb, since you say it is detected when using that utility. Hope this helps you somehow :]

To sum it up, you either have interfering drivers, or have given your device its cousin software from your phone, a very small difference in terms of observable functionality assumably, but large for accessing the fastboot function.

  • Well, that's disconcerting. I'm usually very careful when flashing ROMs but I do also have a Nexus 4 so this is entirely plausible. I've launched Apps like GMail etc and I do get the 'multiview' view (list on the left, content on right) - Is there a more definitive way to determine if it is the wrong ROM? – Illizian Apr 12 '15 at 10:33
  • I believe that grouper is the name for the 2012 Nexus 7, while flo is the 2013 Nexus 7. – wecsam May 6 '15 at 23:59
  • Flo (WiFi) and Deb (3g) 2013 Nexus 7 tablets , AKA razor and razorg. Grouper (WiFi) and Tilapia (3g), 2012 Nexus 7 tablets, AKA nakasi and nakasig . Here is a link for Google Factory Images, the Nexus 7's are about 1\2 - 2\3 way down the page. – HasH_BrowN May 12 '15 at 20:17
0

I had the same problem, but it turned out that adb didn't have to see the device in order for fastboot to see it.

I'm guessing you want to flash Android 5.0 to your Nexus 7?

I just did that by following these instructions. An extra thing I had to do was adding a udev rule, as described here. (However, I removed the GROUP ="plugdev" part of the rule, since other sources omitted that.)

  • erm, adb can see my device and fastboot cannot. I need fastboot in order to flash a new ROM etc. but thanks for taking the time to answer. – Illizian Oct 24 '14 at 8:59
0

I experienced the same thing and I found that it was because the USB ID was different in fastboot mode.

The answer by poolie to the question Android fastboot waiting for devices helped me solve my issue on Fedora 22.

Rather than restarting the udev service, I issued the command:

sudo udevadm control --reload-rules

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.