0

I was trying to enable writing titanium backups to the SDCard by editing the file:

/system/etc/permissions/platform.xml

However I was not paying attention and now everytime I boot up I get spammed with error messages "Unfortunatley, the process com.google.process.gapps has stopped". All apps also produce a force close saying about the same thing. Continuously. I can recieve calls and open up a couple of apps but only by the small window between closing error messages. Here are the steps I took when editing the platform.xml

First I edited the file as suggested:

Original:

Add the media_rw group:

Then I copied the file back to the SDCard. After that I overwrote it in /system/etc/permissions. Not realizing the permissions were incorrect. I restarted the device and started getting errors. I assumed it was the file permissions so I started up ADB and entered the following lines:

mount | grep system
mount -o rw,remount /dev/block/platform/msm_sdcc.1/by-name/system /system
chmod 326 /system/etc

chmod 644 /system/etc/permissions/platform.xml
chmod 644 /system/etc 

mount -o ro,remount /dev/block/platform/msm_sdcc.1/by-name/system /system

That changed the file permissions so I rebooted by my device and got stuck in a boot loop.

So I rebooted into Clockworkmod recovery and tried to restore a working backup of my stock ROM. Got past the boot loop but still spammed by errors, so I tried to restore just the /system partition from the recovery using Clockwork's advanced tab. Seems like the errors are even worse. I wanted to know if by my description someone could give me a push in the right direction. Does anyone know what permissions the /system/etc folder is supposed to have? I suspect the reason this is happening is because I changed the /system/etc permissions instead of just changing /system/etc/permissions. Please offer any knowledge you have. I've pretty much exhausted the first few pages of Google and I don't want to give up and factory reset just yet.

UPDATE: I gave in and factory reset. However I still think the permissions remain incorrect. I get no errors or problems after factory reset and clearing of dalvik and cache. But if I try to restore my nandroid taken before the problems occured I get the same spamming of errors. A ls -l of those directories would give me some hope.

  • Have you tried to reflash the GApps package? – HasH_BrowN Oct 25 '14 at 0:24
  • I haven't flashed anything new in fear that it was a simple fix. Its not just gapps. Its also everything else Rhapsody, Titanium Backup, All other apps on my phone that present the force closed. That's why I think its a permission issue. – Cameron Oct 25 '14 at 0:49
  • I'll add this anyway - did you clear cache and dalvik-cache in recovery? – HasH_BrowN Oct 25 '14 at 0:52
  • @HasH_BrowN Yes tried that, I believe if someone could check their /system and /system/etc directories andalso the /system/etc/permissions and /system/etc/permissions/platform.xml directories and files and show me the permissions that are set on those directories I could fix it. Would you mind providing this info? – Cameron Oct 25 '14 at 16:29
  • The file is too large for comments and it doesnt qualify as an answer so i cant post it. – HasH_BrowN Oct 25 '14 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.