8

I have an Android phone and a notebook running Windows 7, both are Wi-Fi enabled. Both devices are on the same network and they can't see each other (I can't ping phone from notebook and vice versa). But, to make it more weird, let me show you my network structure.

      Name  -       OS  -   IPv4 Address
----------------------------------------
    Router  -           -    192.168.1.1
ComputerXP  -    WinXP  -  192.168.1.103
ComputerW7  -     Win7  -  192.168.1.104
NotebookW7  -     Win7  -  192.168.1.106
 Telephone  - Android4  -  192.168.1.109

Now, ComputerXP and ComputerW7 can ping all devices in given network. NotebookW7 and Telephone can both ping Router, ComputerXP and ComputerW7. The only connection that does not work is Notebook7 <--> Telephone.

I have previously had this problem, I tried restarting NotebookW7, Telephone and Router, disabling and re-enabling Wi-Fi connection and firewall, pinging anywhere and nothing was working. Later on when my dad came home, I wanted to show him this situation, but suddenly I was able to connect to NotebookW7 from my Telephone like magic. I was happy that the issue got fixed. I stopped using this connection for a while and now I wanted to establish it again and guess what, it's again not working. I have no idea what is going on.

I used ping on Windowss and Ping & DNS on Android to test ping.

EDIT 1: For some reason, I was not able to ping ComputerW7 using my Telephone for a while. So in my Telephone I started external software for managing files. I added new network place with IP Address of ComputerW7 (192.168.1.104) and pressed test connection. It was doing something for a while and then it printed "Test successful". I went back to Ping & DNS, and re-pinged same IP Address and it started working for some reason. I did same thing with my NotebookW7, but I got "Test not successful" in my file manager.

EDIT 2: Little bit more weirdness. I added one more Android Phone (lets call it just Phone) to the network and checked all possible pings from outside to the Phone. Nothing worked. Then I tried to connect to VLC Player at ComputerXP using Phone and it worked. After that I was able to ping Phone from ComputerXP. Not really sure how this works. Only difference is that Phone has Android 4.2.2, but Telephone has 4.1.2.

EDIT 3: New thing I tried was to create Wi-Fi Router from Telephone and connecting to it using NotebookW7, it worked. However, I still was not able to ping it.

  • Good analysis so far (+1 for that). Though I have no real solution to your issue, something that might prove helpful is an app for network diagnosis (the link goes to a listing of relevant apps). Such an app might at least help you figure the phone → laptop part. Good luck! – Izzy Oct 25 '14 at 11:59
  • @Izzy: I downloaded Fing app, and when I started it, it scanned network and found devices I can ping to (Router, ComputerXP and ComputerW7). However, I am not sure if this is the right app to perform this kind of diagnostics. – Zereges Oct 25 '14 at 12:13
  • I have not used any of them either, was just providing a pointer I hoped proving helpful. – Izzy Oct 25 '14 at 19:43
  • Android might not respond to pings in power-saving mode. Have you tried disabling WiFi sleep? Alternatively, have you tried pinging your computer from your phone? – Huey Aug 5 '15 at 12:24
  • @Huey Android phone was not in power-saving mode and even has WiFi sleep turned off. I tried pinging computer from phone and it didnt get any respond. – Zereges Aug 6 '15 at 20:51
2

Are you using a Samsung Android running Lolipop? It is actually locked down and some Chinese hackers actually created the PINGPONG root to enable pinging from a Samsung Android.

http://forum.xda-developers.com/galaxy-s6/general/root-pingpongroot-s6-root-tool-t3103016

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.