If I tap on the dialer on a DroidX and start tapping in someone's number then when enough (usually 3) digits have by tapped in the person's name and number appear about the entry box and I can tap on them to dial.

However, if I go into Contacts and search for that same person by name they are not listed in my contacts.

I'm trying to work out what the disconnect between these "contact" lists are and how to keep them insync.

(I'm logged in with my gmail/google account and have a contact list on gmail which syncs with the phone.)

  • 3
    Perhaps you have two different types - Google Contacts & Phone Contacts. Some phones have that "feature". Also, try pressing the search button (in your homescreen) and entering the details - see if the contact shows up there.
    – Sparx
    Apr 24, 2011 at 4:42
  • Tried search on homescreen and from almost everywhere else but no luck. It does appear that I have two different lists and as you say it looks like a Google Contacts list and Phone Contacts. I can see these friends on the Phone Contacts list but if I hit the search button on this list it takes me to the search for All Contacts and doesn't find them there. The only way I can get to them is to scroll there on the Phone Contacts.
    – Guy
    Apr 26, 2011 at 5:04
  • My phone (a Nexus S) doesn't search as I enter digits -- that sounds like a nice feature. But I sure am glad I don't have the "two separate sets of contacts" feature :)
    – offby1
    Dec 5, 2011 at 4:08

4 Answers 4


Can it be that you have unchecked certain contacts to be displayed ?

Go to contacts, press menu, more , display options and verify that you really display the names you want from the options on that screen.

  • When I go to menu, more, there are 4 options: 1. Manage account, 2. Settings, 3. Share name cards, 4. Import/Export. There's no "display options."
    – Guy
    Apr 26, 2011 at 4:52
  • @Guy: More is just an extension to the menu itself - everything that doesn't fit on the main menu, goes to more. On my phone there are lots of options, but f.i. the Import/Export is in the main menu, not the more. Are you sure you don't have display options in the main menu ?
    – Edelcom
    Apr 26, 2011 at 6:51

Go to Contacts > Menu > Display Options, click on your Google account and make sure the box for "All Other Contacts" is checked.


When I looked at my contacts online, most were part of a group called "My Contacts". These people could be searched in the contacts app and in the phone dialer.

There was another group called "Other Contacts". These were only searchable in the phone dialer. I found a "fix". First, I moved these over to the "My Contacts" group on the web, synced my phone, but it didn't fix it. So I tried to find where the setting was to display these people in the contacts app. For me (running a custom rom similar to stock on an HTC Sensation), there was a drop down list at the top of the app that said "Phonebook". When I saw the accounts in there, my Gmail account said it had all 2047 contacts. But what I didn't realize was: there was a sub-menu. All categories in the sub-menu had checkmarks except the one called "(Ungrouped contacts)". When I put a check mark on that group, all the functionality was restored, and the missing contacts and searchability was back in the contacts app.


I have just solved the same problem. Under my 'People' app there is a dropdown in the top left called 'Phonebook'. I selected this and had a number of lists that were displaying contacts. When I selected my Google account I noticed a number of check boxes and one of them was clear. I checked this box and can now find all people that I used to have to find via their phone number.

  • it would be great if you could include Screenshots :)
    – benjamin
    Dec 8, 2015 at 12:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .