10

Okay, so I've seen this question asked before, but literally none of the solutions has ever worked for me, and I've now gone through three phones and six iterations of Android, multiply versions of the Google keyboard, and multiple keyboards and the issue just will not fix. I've seen this common question asked before:

At some point, I mistyped the word "don't" as "Dont" and saved it as an autocorrect. Now everytime I type "don't" it autocorrects to "Dont", with a capital and no apostrophe.

The difference between that question and mine is that I've been trying to fix this for YEARS now. It started on the first version of the Motorola Droid back in 2010 or 2011. Using the stock keyboard, I mispelled "don't" and that mistake would haunt me forever. In 2012 I switched to the Galaxy Nexus. With the stock keyboard, the mistake stuck. I searched for a solution, and only found things like "uninstall keyboard" or "uninstall updates" or "clear cache and data" or "try a new keyboard." The only thing that worked was using a new keyboard, so I used Swype and SwiftKey for most of the Nexus's life. Upon release, I was eligible for an upgrade and rushed to the HTC One M8. The phone was superb... I loved everything about it. Except it's big-keyed keyboard... so I switched to the default Google Keyboard. And guess what was back? My awful "Dont" type. I considered moving to SwiftKey or Swype or any of the other available market keyboards, but the truth is I really like the stock keyboard. I tried reclearing caches, data, clearing out the Search history (like another thread suggested), long-pressing on the word, turning off voice input and long pressing, checked my personal dictionary. The issue persisted. I even side-loaded the beta Android L Google Keyboard, and it immediately reappeared. I totally uninstalled Google Keyboard, Google Voice Input, Google Text to Speech, and used CCleaner and The Cleaner to clear all of my caches and data, and when I reinstalled Google Keyboard, it persisted. I tried the same thing again and re-sideloaded the Android L Google Keyboard... same issue. Froyo, Gingerbread, Honeycomb, Ice Cream Sandwich, Jellybean, and now KitKat and the issue has still persisted. Three different phones, three different manufacturers, three different UIs. The issue still persists.

Please, someone, help. :(

(Why, you may wonder, is it such a big deal? First, it's not fun to answer professional emails from my phone and constantly spell "don't" as "Dont." I'm a teacher, and this looks extremely stupid to parents who expect their kids are learning from the best.)

4

When you type in "don't" try holding your finger on "Dont". You should get something along the lines of:

Never predict "Dont" again?

Press yes, and you should be sorted!

0

Try the free User Dictionary Manager. It lets you clear out your predictive user dictionary.

0

I have an HTC (Android), when you have your keyboard up look at the comma to the left of you spacebar. Above the comma is what looks like a gear (the symbol for settings) hold the key down until the gear is present. That should take you to your input settings and the personal (or user) dictionary is in the list. Click on it, to delete words go to the 3 vertical dots in the top right corner. Click on delete and you will have boxes appear by all the words. Check the ones you want to get rid of.

0

Open your keyboard. Hold down the microphone key just to the left of the spacebar, and when an icon with sliders shows up, let go. You will get a pop-up that says 'Input options' and it will give you two options. Select 'Android keyboard settings'. After that, scroll down until you see a tab that says 'Personal dictionary' and select that. Select the language you use to text, and then find the word you want to change/delete from your autocorrect settings. Select it and then hit the trash can icon at the top right corner of the screen. Hope this helps!

0

if you have the auto fill or predict next word options enabled, then you will see the current word which you are typing just above the keyboard.

Long press on the word which is displayed and select the required option such as delete from dictionary or edit.

0

For OPPO :-

Settings/ Language & Input/ Swype for OPPO/ My Words/ Edit my Dictionary

Then highlight word and into the Red Bin with it

0

Hold the word down that you want gone (Don't) and it will say ""Don't" will be removed from learned words". What it will say will probably vary with different phones. Hit "okay" and you'll be all set. They only words you can't delete are words that have spaces. So if you wanted to get rid of the word "Do n't", it wont delete. It's annoying as all hell and wish they'd figure that out and let us know. Soon. I hope this helps.

0

My problem was with the word "too", i had spelled it "t p o" with a "p" in the middle. And i couldn't hold my finger on it till it gave the option to remove it. I kept typing it incorrectly a few times till it showed up in my recently used words, the words that show up on the list above the keyboard when i haven't started typing yet and the cursor is just blinking. It was the 4th or 5th word on the list. At that point i was able to hold my finger on it until it gave me the option to remove and delete it. Done!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.