2

I have a Huawei Honor 3C with android 4.2.2.

I can't specify an app as default SMS app. In settings for Messaging (the standard SMS app in this phone) the clear default button is disabled!

I turned on SMS in Google Hangout, but still in settings of it the clear default button was disabled.

When I say text someone some text in Google Now it says No SMS app installed!!

setting screenshot Google Now screenshot

How can I set the default SMS app for this phone?

  • As Jacob's answer didsn't solve the issue for you: Could you try installing another SMS app capable of taking that place, e.g. 8sms, try making that the default, and see if GNow does accept it? – Izzy Jun 9 '15 at 5:22
2

My phone is running on Jellybean 4.1.2, which means the solution to your problem may be a different solution for mine.

But, what I can suggest for you is to either disable Google Hangouts, as well as the SMS function therein, hopefully isolating Google Now's default SMS setting to Messaging, i.e. the stock Android messaging app.

Other than that, you may find doing a Factory Data Reset may do the trick. Just keep in mind, you may want to go into your settings and manually back up all of your personal data, like contacts, musics, photos, etc. as well as your Google Account just to make sure.

I've done this before to fix my Android phone a little while ago. If done right, you should still have all of your personal data automatically synced and ready to go by the time the phone resets itself. I'm going to do the same tonight, just to see if it helps.

If it doesn't, though, and you MUST HAVE a way to text message people using your voice, execute web searches, or anything else like that, then "Dragon Mobile Assistant" by Nuance is a more than viable alternative. I have it currently set to a double press of the home button thanks to a third-party app called "Home2 Shortcut". It works very well and is easy to set up. I really hope this helps.

  • 1
    @Rahmani Did Jacob's answer solve your issue? If so, please consider "accepting" it (ticking the check-mark next to it) to make it obvious to other possibly affected visitors. Thanks! – Izzy Jun 8 '15 at 11:07
  • @Izzy, no, it didn't. – Rahmani Jun 9 '15 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.