42

I've got an invite to the new inbox by gmail service. I downloaded the app, but I can't seem to make it the default mailing app on the phone. (when I receive new emails, I get system notifications from the gmail app and not from the inbox app). I tried to list the inbox app as the default mailing app using "Default App Manager" from the play store, but I guess that deals more with handling "mailto" commands and such, not with system notifications. how do I get Inbox to show notifications instead of gmail? I kinda randomly got 2-3 notifications from inbox while trying to make it work, but I have no idea why it happened.

thanks in advance!

  • Have you tried disabling the gmail app? – 1990clb Oct 26 '14 at 10:47
54

Enable notifications for Inbox:

  • tap menu icon
  • tap settings (just above Help & feedback" at bottom of screen
  • tap your email address
  • check "New messages" and your choice of Vibrations, Lights, and sound.
  • Tap "Turn off Gmail notifications" & confirm (if displayed)

Disable notifications in the Gmail app (if "Turn off Gmail notifications" is not displayed in Inbox):

  • swipe from left to right to expose mailbox list, labels, and settings
  • scroll down to "Settings"
  • tap your email address
  • uncheck "Notifications"

(repeat for each email address if you have multiple set up). You'll be able to see your mail from either app, but notifications will now come from Inbox instead of Gmail.

  • 5
    There is been an update for Inbox that allow you to directly disable Gmail notification from the settings menu – JF Dion Nov 17 '14 at 19:11
  • yep, that's the answer. they added this feature after I asked this question – GuySa May 14 '15 at 11:13
  • 1
    Just a note to others, I am new to android and couldn't figure out why my IFTTT notifications were not working with inbox. The above answer is correct, but it turns out if its is specifically an "if gmail then *". inbox won't display the notification. It needs to be "if email then *" for inbox notifications. – hidden-username Jul 13 '15 at 18:29
  • Another note : In "manage account", if you select 'google' and then one of your email, you can choose what apps sync your data for that account, so you can unsync your gmail if you want to. Ad for those using gmail with some email adresses you can unsync inbox for those. – Salix Jul 17 '18 at 21:12
1
  1. Go to apps>gmail and click disable (you may have to uninstall updates first)
  2. Enjoy

EDIT: Please use the other solution if you have more than one gmail account

  • That's not really a great answer - Gmail still has a use...especially considering it serves much more than just your Google email accounts now. – Rockdocta Nov 24 '14 at 15:25
  • Also, for people, like me, who have multiple gmail accounts tied to their device, but not all of them are enabled with Inbox. This solves one problem, and causes another. – Ryan Conrad Dec 30 '14 at 0:44
  • Yes, I have used the other solution as well – ollie299792458 Jan 6 '15 at 18:32

protected by Community Nov 7 '14 at 9:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.