0

I have a device to which I recently flashed CM 9 which I use for testing backward compatibility in apps. However, adb doesn't seem to recognise it.

adb devices outputs the following when it is connected:

List of devices attached 
????????????    offline

And also sometimes this:

List of devices attached 
????????????    device

When it says device, I can use normal adb commands, however, if I connect another device it will stop working (because the device has no identifier so adb will always prefer the other device). I've tried this on both OS X and Linux, and the same device running CM11 works fine with adb. I've tried several different USB cables and also other devices, all of which work.

So, has anyone else had this issue/resolved it? Any other ideas on how I might try and work out the cause of this issue?

2
  • You might check with lsusb that the device ID is the same as before you flashed CM9. If not, you will need to edit the udev config again to make it work.
    – Dan Hulme
    Commented Oct 27, 2014 at 12:17
  • Have you checked with lsusb and updated your udev rules, as Dan suggested? Did it do the trick? Is your issue solved meanwhile? Please remember you can always answer your own question ;)
    – Izzy
    Commented Jun 8, 2015 at 10:46

0

You must log in to answer this question.

Browse other questions tagged .