I have two Google accounts, one for work and a personal one for my Android phone.

I have both accounts synced to my phone because I often have work to do on the road. I recently noticed while logged in to my work account in GMail that all of my personal account's phone contacts appear in my work account's contacts. I never asked to have the contact lists merged together, nor did I add one to the other.

They may have been logged in together on a computer at one point before, but I can't remember. My personal account is not currently logged in on the same computer as the work account, so I'll be able to delete them from the list now. I just don't want this to happen again.

Is there a setting to suppress this behavior?

5 Answers 5


You can download Google Contacts app.

When you want to switch accounts, just tap the profile picture thumbnail on the top right, and select the desired account.

Switch Google contacts list in Google Contacts

You can select either Google account, or view an unified list (for whatever reason, or if you later change your mind)

When adding a new contact, make sure that you are selecting the correct account. (you can view it at the top as Save to)

Of course, both accounts need to be connected to the device, and sync should be enabled.

And if you mixed up your contacts...

From your comment:

[...] it seems that the phone's contacts are syncing to both accounts. [...]

You can switch accounts to confirm, and if it happened, you may want to delete the duplicated contacts, and then switch to the other account and move your contacts to the right place.

  1. Select the contacts you want to move (tap and hold)
  2. Press the menu button (or the three dot menu at the top)
  3. Select your desired action:
    • Select all
    • Delete
    • Move to another account
    • Add label (Group using tags)

For more details, you can visit the google contacts support site.

  • Note: This does not work for moving contacts between personal and work profile.
    – kynan
    Apr 18, 2020 at 17:56

Your phone's contact might be synced with your gmail account from you phone. To prevent this from happening, you can disabel contact syncing option with your gmail accounts.

Go to settings-->Accounts-->Google-->select_your_account.

This will show the items that you have synced with the account. Just deselect Sync Contacts in the list and now your phone's contact will not be synced with the mobile. Selecting this option with particular account will sync contacts only with that account.

  • That's the tough part. I do want the phone's contacts to sync to the personal Google account, just not to the work Google account. It seems that the phone's contacts are syncing to both accounts. I was hoping for some sort of one-way sync of the work account to the phone, but not the phone to the work account.
    – Phoenix10k
    Oct 27, 2014 at 23:38

Use different e-mail client apps for each of your e-mail accounts. Turning off sync is not an option, but if you use separate apps, it should do the job. Maybe keep GMail for your work account, and try another app for your personal account, where you can accept a few changes here and there.


There is an App called Island which allows you to have separate app profiles. This allows you to separate app data without using two different apps for work and private.

This also allows you to separate your contacts. App claims it supports Android 5.0 and higher, I only tried it on Android 8.1, though.


If you strictly want to separate work and personal, then create additional user in Mobile.

Settings > Users > Add User

In your current User keep one Google account, and remove another.

In newly added user, set with removed Google account.

You can name one user as personal, and another as work respectively.

You can switch between users easily in one tap, most probably this option will be in top near notifications.

While adding contacts, add in respective user only to distinguish clearly.

By this way everything is seggrigated, and mails, contacts nothing will be mixed or messed up..

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .