0

I can install Safestrap 3.72 (Safestrap-JFLTE-3.72-kk-B01.apk) and then install and use the custom recovery without a hitch. However, once the custom recovery has been installed and the phone is rebooted, the Safestrap GUI app no longer runs (I want to run it in order to uninstall the custom recovery, and the manual instructions for uninstalling from a shell prompt that I found here didn't work). Every time I try to start it, I get the error message

Unforunately, Safestrap has stopped

I've tried reinstalling the APK, both with and without uninstalling the app first. It always installs successfully, and SuperSU requests root permissions the first time I run it after reinstalling, but it always crashes immediately. I've also tried uninstalling and reinstalling BusyBox.

This also happens if I start from scratch, by re-flashing the stock NC5 ROM and doing a factory wipe/reset from the stock recovery (yes, I've also tried wiping from the Safestrap recovery). Starting from the out-of-the-box config, I follow this process:

  1. Root the phone using Towelroot
  2. Install BusyBox
  3. Launch the BusyBox app and click INSTALL to install the tools
  4. Install Terminal Emulator
  5. Launch Terminal Emulator and invoke su and then setenforce 0
  6. Install the Safestrap APK.

At this point, the Safestrap app runs just fine, and I can install the custom recovery. However, after that, Safestrap won't run anymore (crashing immediately with the error message above).

Phone info:

  • Model: SCH-I545
  • OS Version: KitKat 4.4.2
  • Build: NC5 (same issue if I upgrade to NG6)
-1

Okay, it turned out to be something silly. The problem is that SE status reverts to Enforcing when you reboot. So, you have to set it to Permissive with setenforce 0 again before the first time you use Safestrap after a reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.