2

I have had my phone (Samsung Galaxy S4 GT-I9505, Android 4.4.2) rooted for a while (can't remember exactly how I did it now) but last night I exhausted the battery and when I charged and powered back on I had lost root. SuperSU quits with error message "There is no SU binary installed and SuperSU cannot install it. This is a problem!"

I have tried to re-root following these instructions but when I do the Volume Up + Centre Home + Power combination I don't get the warning message about installing custom OS, instead I get:

Android system recovery <3e>

KOT49H.I9505XXUFNA5

Volume up/down to move highlight; power button to select.

  • reboot system now
  • apply update from ADB
  • apply update from external storage
  • wipe data/factory reset
  • wipe cache partition
  • apply update from cache

[Exposed Android with red warning triangle]

# MANUAL MODE #

-- Applying Multi-CSC --

Applied the CSC-code : BTU

Successfully applied multi-CSC

Now from here I don't seem to be able to flash TWRP because nothing shows up in Odin when USB is connected. If I select "reboot system now" I get back into un-rooted Android (annoying because I make extensive use of multiple profiles on Titanium Backup); if I select apply update from ADB then the S4 then appears as a device when I run adb devices:

List of devices attached
6496ea42        sideload

But still nothing on Odin.

Can anyone advise how I can re-flash TWRP and re-root?

Many thanks

Tristan

  • 1
    Chances are that the device is rooted, just SuperSU is not installed properly (this has happened me a few times, and the Binary install through SuperSU failed, flashing a zip worked). Did you try flashing the latest SuperSU zip at all? It seems you are booting into Recovery and not download mode, use the other volume key Volume Down and try to boot into download mode for Odin. – RossC Oct 30 '14 at 11:19
  • How can I flash the latest SuperSU zip? Also you are right that I have been using Volume Up not Volume Down as instructions state... Oops. – tristan Oct 30 '14 at 11:32
  • 1
    You can't now if you have the stock recovery. IF you have a custom recovery you can flash it like any normal zip. However, you are probably going to have to re-root now or flash a stock rooted ROM. If you can get into download mode now you should be able to flash TWRP or Philz or CWM or whatever recovery you want. – RossC Oct 30 '14 at 11:35
  • 1
    Excellent, it's working now (had to switch to CWM recovery for some reason TWRP was hanging). If you post an answer I will accept. – tristan Oct 30 '14 at 12:46
1

On the Samsung Galaxy S4 (GT-i9505) Volume Up, Power and Home is to enter mode. Volume down, Power and Home is to enter 'Download Mode'. From download mode you can make the device visible to . From Odin you can flash a custom recovery, or root the device with CF Auto Root and other methods such as flashing a pre-rooted stock ROM for example.

If your device shows as not being rooted, when previously it was and you have not unrooted it manually, this could be an issue with the SuperSU binaries, and sometimes installing these via the app, or via the 'recovery' option within the app can fail. You can download the SuperSU zip from Chainfire and flash it in a custom recovery.

Generally the safest bet is to backup anything you need, flash the Stock ROM through Odin, and root, or flash a pre-rooted stock ROM. Then you can flash a custom recovery and from that recovery flash whatever you need.

  • You can also add that you can force the device to go into download mode, by using cmd adb reboot download. Which is especially helpful when your device only boots up recovery mode when powered on. – HasH_BrowN Oct 31 '14 at 17:58
  • Thanks @HasH_BrowN! Do you want to add another answer or will I add that here when I get to a pc! Very useful information – RossC Oct 31 '14 at 18:07
  • 1
    No you have an answer, just add it to yours. I had the reboot into recovery mode happen for full hour last night on my S2. I tried everything, what a PIA! – HasH_BrowN Oct 31 '14 at 18:10
  • When i was trying to go to download mode the phone would attempt to start it, but would show Odin mode for split second and then go into recovery mode. I tried unplugging battery and numerous other combinations of things. So finally I didnt touch it, just to normal boot and it would still go to recovery mode all by it self (spooky). While in recovery mode I opened ADB on PC, got it to reboot to download – HasH_BrowN Oct 31 '14 at 19:27
0

You should also look into making or buying a USB jig for forcing the phone I to download mode. It's a simple device that plugs into your usb when the phone is off, and resets it directly into download mode.

This will save your phone if you ever soft brick it, and it just dang handy to have for situations like yours.

Here is a link to how ti make one from XDA.

http://forum.xda-developers.com/galaxy-s2/help/guide-how-to-make-usb-jig-reset-binary-t1604707

P.s. They are a Samsung thing, and do not work on any other brand phone.

protected by Matthew Read Oct 19 '15 at 4:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.