I need to root my Samsung GT-I9082 (also known as Grand Duos) with Android 4.2.2 but I have no Windows computer (I have a Linux one).

Which are the preferred methods?

It seems z4root does nothing (seems just to crash).

Towelroot supports most Samsung devices. Based on a quick Google search, it sounds like it has been confirmed to work on GT-I9082. It's extremely simple:

  1. Navigate to towelroot.com on the mobile device.
  2. Tap the big red lambda (λ) to download the APK file.
  3. Find the APK file, either in the notifications or the Download folder, and tap it to install the app.
  4. Open the app and tap the make it ra1n button.

That's it. You should get a message within about 5-10 seconds telling you that you have root access. You don't need a PC, and you don't even need to power off or reboot. It's so simple it's dangerous, because one doesn't need to have a modicum of technical ability in order to gain root access.

  • It says "This phone isn't currently supported" – Envite Oct 31 '14 at 15:50
  • Since I was able to google up several references for using Towelroot on this model, I suspect that it's your firmware version that's not supported. I've seen this message when trying to use Towelroot on an S4 with the most recent firmware update (NG6). The workaround is to downgrade to previous version of the firmware, run Towelroot, then upgrade back to NG6, but I'm not sure if that would work for your device. – Adi Inbar Oct 31 '14 at 17:55
  • I've also read this article about forcing Towelroot to run anyway. I haven't tried it myself yet, but I plan on trying it out to root NG6 firmware without the downgrade trick. I'll come back and report my results. BTW, be very careful if you want to try out the firmware downgrade trick, because it can be dangerous. I wouldn't recommend it unless you have a nandroid backup or use a separate device for testing. – Adi Inbar Oct 31 '14 at 17:58
  • Tried the towelroot article. None of the strings worked. And no downgrade possible, it came with 4.2.2 from factory. – Envite Oct 31 '14 at 20:01

protected by Community Jan 10 '15 at 18:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.