0

My Phone runs CyanogenMod 11. I registered in WhisperPush via the Settingsentry and got the verification code. I do have a Google Account, the phone is new and I haven't installed any apps yet.

Now I wanted to text with my contact (he's using TextSecure) via WhisperPush/TextSecure. When he sends me a message using TextSecure, it's shown to him that it's sent encrypted, but I won't receive any message at all. On the other hand, when I send a message, it's send as a normal text without any encryption at all.

I tried to enter the verification code somewhere, but can't find anything, permissions should be also fine, at least I allow WhisperPush everything.

How can I get WhisperPush to work?

Hint: WhisperPush is integrated with CyanogenMod, so Google Cloud Messaging shouldn't be involved.

Update: I tried it with another contact, who uses TextSecure as well. While I still won't get any encrypted message and the messages I send are still plain text, after unregistering and re-registering from WhisperPush I noticed that I've the public key of my contact in my list, he had mine as well. So it seems there was a key-exchange, but somehow the messaging app(?) doesn't know it can communicate with this contact using WhisperPush/TextSecure.

Update II: I just installed the TextSecure (now Signal) app from the Google Play Store. Works flawless.

  • I can't find that app (could you provide a market link?), but it might be it uses Google Cloud Messaging. CM doesn't ship with the GApps, which are required for that. Do you have the Google Apps installed on that device? – Izzy Nov 2 '14 at 23:36
  • @Izzy WhisperPush is directly shipped with CM article. I do have (I guess all) Google Apps like GMail, Maps, PlayStore etc. It would be a bit weird if CM includes software which needs something you have to install afterwards... – fukurai Nov 3 '14 at 10:13
  • Yupp, you're right. I wasn't aware of that fact (your question didn't state it ;) In that case, GCM shouldn't be involved here. – Izzy Nov 3 '14 at 10:48
  • 1
    @Izzy: CM's WhisperPush implementation actually does require GCM. A ticket was filed at one point asking them to remove this requirement but it was marked as "won't fix". – eldarerathis Nov 5 '14 at 0:31
  • 1
    @Izzy, I'm quite sure I've the GApps installed. On the link eldarerathis provided they talk about the Play Service Framework. I guess it's the Google Service Framework which I have and according to the Privacy Guard has all permissions, not sure if there lies the problem. – fukurai Nov 5 '14 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.