0

I have a Micromax Canvas A1 device. I can open Play Store and can search the apps. But, when I click Install, it just shows (endless) download animation and no actual downloading happens.

An example:

enter image description here

Process is stuck in installation phase and no further progress nor even any notification hapens.

I've tried so far:

  1. Clearing Google Play Store data and cache.

  2. Doing factory reset of the device.

Still nothing. Anything else, I can try?

  • Have you tried using other network connection? Perhaps there is an issue with the connection, or firewall? How about downloading the app from the Play Store website? – Andrew T. Nov 4 '14 at 6:22
  • Have you tried clearing the cache and the data stored by the Google PlayStore App ?? If not then I would advise you to try clearing the cache and the data, and restart your device. Upon restarting open the Google PlayStore and check if you can everything starts working fine for you. I am pretty much sure that will do the trick for you. – Peter Carlos Nov 4 '14 at 6:57
  • @PeterCarlos - Thanks for the advice, but as I've mentioned, I've already tried clearing cache, data and uninstalling update. After rebooting, having the same issue. – Kunal Nov 4 '14 at 6:58
  • @Pankaj Oops my bad I haven't seen bottom of your post. I guess the problem is somewhere with the network only,Okay do one thing stop the download and ask your friend to tether for you connect with it and again try downloading the app and check if that works for you ? – Peter Carlos Nov 4 '14 at 7:03
  • @PeterCarlos - Well, now I can install using my 3G connection, but not with WiFi and Tethering. Is it a WiFi problem specific for playstore? – Kunal Nov 4 '14 at 7:09
1

Backup your phone. Do a hard data reset (note, that this is different from a factory reset):

  1. Press Volume Up + Volume Down + Power Button all at once.
  2. Press Volume Up.
  3. Go to recovery and then select wipe data/factory reset.

If you are facing any troubles, then this link should be helpful for you.

protected by Community Nov 16 '14 at 7:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.