Whenever I try to install Voice Search I get "install failed" error in the notification bar. Supposedly it has something to do with signatures but I know better than to ask Cyanogen about it. Any ideas?

1 Answer 1


I spotted this advice on the post on the Google Mobile Blog announcing the new Voice Actions. At least one person in the comments claimed success.

Just run the following commands to uninstall the old system apps if you use a custom rom.

adb remount

adb shell rm /system/app/GoogleQuickSearchBox.apk

adb uninstall com.google.android.googlequicksearchbox

adb shell rm /system/app/VoiceSearch.apk

adb uninstall com.google.android.voicesearch

Then they will install just fine from Market (from the US Market). MarketAccess set to TMO US will allow you to find them.

  • I was afraid of that . . . not a big fan of commands like "adb shell rm /system/app/VoiceSearch.apk" but I'll try it. Worst case is I have to wipe and start over, right?!
    – tooshel
    Commented Aug 17, 2010 at 20:42
  • 1
    Okay, that worked. Had to install "Voice Search" and "Google Search" from the market after deleting and uninstalling per the directions above. For those that don't know you need to get the SDK, install the Android USB Driver, and turn on "Debug Mode" on your phone so you can run ADB commands from the command prompt in the tools directory. I guess if you have Cyanogen you know all that already. Nevermind. But I did have to delete the search gadget and then re-add it to my home screen. BAM! Voice Search heaven. Can't wait for it to fail when I show my iPhone friends!
    – tooshel
    Commented Aug 17, 2010 at 20:57
  • Well, that is the risk when you root and install custom ROMs, innit? I'm glad it worked out, though.
    – Al Everett
    Commented Aug 17, 2010 at 22:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .