I was updating the firmware on kies for my galaxy s and it got half way through and then said error and is no frozen on the downloading 'do not turn off' screen, I have taken out the battery and put it back in, and tried the hard reset, which leads me to a phone symbol, a computer symbol and an error symbol in the middle, help plzzzzzz

2 Answers 2


I had the same problem (except I didn't use Kies, I had the problem after the first OTA Update)

Here are the steps I did to get my device back in a usable state:

Keep in mind, this will revert your phone to a rather old (android 2.1) version of TouchWiz. You may want to see if there are newer ODIN files available.

You will probably need different files anyhow, as the ones I have below are for the Galaxy S Vibrant.

Also, I take no responsibility if this does not work for you, or your phone explodes in the process. These are the steps I took, and they worked for me. Good Luck.

  1. Download ODIN3 1.0

  2. Download 512 PIT

  3. Download JFD tar

    • Note that all 3 of those are from the same thread. It also wouldn't hurt for your to read that post too.
  4. Open Odin, plug in your phone, then put it into download mode.

    • To expand on this because a lot of people were asking "how to put in download mode". The easiest way I found to actually do it, if you can can connect via ADB is to do the following:

    # reboot download

    If you can't get that to work, try how i mention below (phone off, battery out, hold vol+ & vol-), or try searching these forums for "vibrant download mode" you will find other things that "work" for people

  5. load the PIT file in appropriate area.

  6. load the .tar file in the PDA area.

  7. DO NOT check 're-partition'.

  8. Click start, let it finish.

    • At this point ODIN failed on me. and I got the "mobile-!-pc" image.
  9. Now, pull your battery and unplug USB

  10. I also took out the SIM and sdcard at this point.

  11. bring the phone to download mode again

    1. plug the USB back in (the phone should be off)
    2. Hold down vol+ & vol-
    3. Put battery back in
    4. press power
  12. re-run ODIN as mentioned above

Don't give up if this doesn't work. If you get the device to boot, even if it is to the "Error Screen", there is a possibility of recovering.


You should experiment with rebooting via the various key combinations / battery pulls / USB plugged-in-ness below first. Sometimes the phone can be jolted out of the bad mode it's in by doing that. If the firmware was partially written though, you'll have to do Odin as Ryan suggests.

I basically agree with Ryan's answer, but I'd use at least Odin 1.5. Here's Odin 1.7, it includes the 512 PIT file.

For the GT-i9000 (international Galaxy S), get firmware from this XDA thread. You probably want the newest for your region (excluding Gingerbread, since it hasn't been officially released).

I also recommend checking re-partition in Odin. This will wipe 100% of your data, however.

I think the easiest way to get into Download Mode is through key combinations. For the i9000, just hold Power + VolDown + Home until the phone reboots, then let go of Power only; after a second you'll get to a yellow triangle with an Android in it. For the Vibrant, remove the battery, plug into USB, hold VolDown + VolUp, and insert the battery.

  • Yes, finding the latest ODIN is a good idea. I really just posted the exact steps and tools I used when I had this problem. Apr 28, 2011 at 18:21
  • 1
    Yep, I upvoted your answer ... I just had too much to put in comments (and didn't want to take over your answer through edits). I've spent way too much time playing with Odin :P Apr 28, 2011 at 18:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .