9

I live in Hong Kong, and the Play Store displays everything in the local Cantonese language. I have set everything I can (Android language, Account language, even the app locale via Xposed Module "App Settings") to English, but I still see all the categories in the store in Chinese. Can someone help me change those to English?

(Click image to enlarge)

IMG:

  • 1
    If I'm not mistaken, Play Store also uses IP address to check the location, though I'm not sure if it also affects in-app language. – Andrew T. Dec 16 '14 at 7:25
8

Short answer: You can't!

From How can I switch language in google play?, you used to be able to work around this via a proxy:

Basically the market is determined automatically based on your IP. You can change some local country settings from your Gmail account settings but still IP of the country you're browsing from is more important. To go around it you'd have to Proxy-cheat. Check out some ways/sites: http://www.affilorama.com/forum/market-research/how-to-change-country-search-settings-in-google-t4160.html

For the current versions of Google Play, it will always go for your IP address and geo-ify it. Therefore, if you're really determined you can use VPN to route through some servers with Geo-IPs.

If VPNs are not a solution for you (They weren't mine: Too expensive, too risky and depends on trust of the host, ...) you can mess with a GeoIP database (and have Hong Kong become US), alike as this XKCD comic:

Now what?

If you're a fan of Google products and want to keep using it, you will have to deal with it, or use the web based market as pointed out in another answer. What I did instead was that I rooted my phone to remove Google Play store after installing Amazon app store, and used it instead.

  • Is this still the case? – Frazer Kirkman Feb 26 '17 at 18:41
  • 1
    I haven't seen any credible sources stating otherwise, so until someone shows me some, probably yes @FrazerKirkman – Unihedron Feb 27 '17 at 2:56
0

The best option would be head over to your Google account and change the Language settings to something you preferred. Once done open the device head over to settings>application manager>Clear the cache and the data stored by the Google play Store and close the app. Once done, try opening the Google PlayStore and this time the language will be changed.

  • That's what I tried already, it did not work. – uncovery Nov 14 '14 at 10:34
  • Well, that's something weird,do one thing create new Google account over web and upon registration select UK/US as country and then again try putting that google account over your device and yes remove the older one and then see if you can see any difference ?? Anyway one more thing which device you are experiencing problem with? – Peter Carlos Nov 14 '14 at 11:29
  • I have two devices, same issue, once HTC One M8 and once old Samsung Galaxy note – uncovery Nov 14 '14 at 13:22
  • No, problem at all you can put the new gmail account created over both of the the device ! Try doing that and see if it can be of any use ! – Peter Carlos Nov 17 '14 at 4:36

protected by Community Mar 29 '15 at 13:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.