K-9 does not seem to find the installed Openkeychain app. OKC works fine and so does K-9 except for this problem. Both programs have been installed from F-Droid and are the the latest version. I am using a Moto G ("falcon") with ParanoidAndroid 4.6b5 without Gapps. APG used to work.

Thanks in advance for any help.


4 Answers 4


Apparently on the "Accounts" screen, one has to long press the account. Menu will pop up. Click on "Account settings". Another menu will pop up. Click on the "Cryptography" item at the bottom. The Cryptography menu will open. Click on "OpenPGP Provider". By default, "None" is selected. Click on the "OpenKeychain" and you're set!

Hope this helps!

  • This may work but in my experience it doesn't "stick". AFAICT (see this GitHub issue) it's an issue with K9 being unable to launch OpenKeychain. Commented Jun 9, 2019 at 8:54

I also struggled with setting up Open Keychain with K9 Mail, and I was able to solve it.

Even though the recipient's key was in Open Keychain, and even though Open Keychain was selected from Settings>Account Settings>Cryptography, when I tried to send to send an encrypted message, it would show the message that said "private mode is enabled but some recipients don't have keys."

What I did to solve it was to open Open Keychain and select the recipient's certificate, click the three dots in the upper right corner, and then selected "Confirm with fingerprints>Finger Prints Match > Confirm Key

That turned the contact a green color in Open Keychain.

Finally, I went back into K9 Mail, and was able to send encrypted emails.

I don't know if my experience was unique, but thought I would share it since it took me hours to solve this problem.


My platform: Samsung Galaxy A9100, Android 6.0.1, with OpenKeyChain 4.8.1 && K9Mail 5.400.

I'm also stucked here and problem is (unperfectly) solved. I tried:

Open OpenKeyChain, click '三' to open left sidebar, select 'Apps', run K-9 Mail here.

Now, check K9Mail->Global Settings->Cryptography, OpenKeyChain is successfully detected.

However, with this solution, I must launch K9Mail from openkeychain app. Hope my experience could provide some help.


I finally found an answer. There is a setting in K-9 to use any encryption app installed.

  • Could you expand this answer at least explaining the steps to do that?
    – Andrew T.
    Commented Mar 20, 2015 at 1:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .