I use gesture (swipe) typing on my phone to enter text.

However, sometimes when I enter certain words, the keyboard suggests emoji icons instead of the word I typed.

For example, when I gesture type the word 'man', I am suggested the male symbol, but if I tap type the word 'man', it works fine and I am suggested the word instead. See images below.

Gesture Normal

As you can imagine this is frustrating when typing quickly.

This happens in all applications.

I'm using a Nexus 5 running KitKat 4.4.4.

How can I disable emojis from being suggested when gesture typing?

4 Answers 4


It worked for me to go into the Text Correction section of the Google Keyboard settings and then to Add-On Dictionaries. Emoji for English words said it was available so I installed it and then removed it. The auto correct of emoji icons has stopped for me since.

  • I had to do this too. The emoji dictionary said "available" but I was getting emoji suggestions. I installed, then deleted, and now I don't get them anymore. Thanks!
    – James B
    Apr 17, 2015 at 19:53

Go to Settings of your phone. Then choose Languange & input. On the default you can see keyboards. Click emoji's setting. Uncheck the Enable gesture typing.


Go to Language & Input Google Keyboard Text correction Add On Dictionaries

Now click on the "Delete" button next to "Emoji for English words"

Done. :-)


I will expand on the answer above for those unfamiliar with android. For android 5.0 Lollipop, go to phone system settings, then choose language and input. Press on Google keyboard under the subheading "keyboard and input methods", then choose text correction. Click on add on dictionaries. The "emoji for English words" listing will be shown as installed. Just press delete and you're done.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .