0

PREAMBLE: I had a weird proxy server config issue that I have now resolved but the answer to which does not seem to be covered anywhere as far as I can tell - so I'm describing the issue then will answer my own question. If you have a similar problem it's just another thing to check off.

MY PROBLEM: I've configured my WiFi to use a proxy server via Settings, WiFi, then long press on Network Name. I have a local Squid proxy server running on 192.168.0.60:3128 (Internet gateway is on 192.168.0.1), so that is the setting I use. However when I run Chrome, it is not connecting to the Internet via the proxy server.

MY DIAGNOSTIC AID: The WiFi server I'm connecting to (192.168.1.1, I'm 192.168.1.xx) is also running an internal VPN so by using an IP Geo-locator (http://www.iplocation.net), I know if I'm connecting to my local proxy server or getting tunnelled thru the VPN to a remote geo-location. (The VPN server does not tunnel local IP addresses and the proxy server is local.) This aspect is not relevant to the actual issue of not connecting to the proxy server. It's a diagnostic aid.

2

In Chrome Settings there is an Advanced option Reduce Data Usage. It causes Chrome to connect to Google servers to deliver compressed pages.

When this option is ON my proxy settings are ignored.

When this option is OFF my proxy settings work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.