2

I recently upgraded my Samsung Galaxy S4 Mini to Kitkat (4.4.2), and I noticed a new behaviour that I'd like to disable: when I'm connected to a wifi network with a captive portal that requires sign-in, and I don't actually sign in, the phone will disconnect from the network after a while, and I have to reactivate that wifi network manually.

That's normally a useful thing to do, in order to maintain some kind of connectivity, but less so when the wifi network in question is the one in the London Underground, where there is no mobile phone signal. While using a normal web browser requires sign-in, there are some apps that work without it, such as Opera Mini and Facebook Chat, and sometimes I'd rather not spend my time on dealing with the sign-in page. Disconnecting from the wifi network will in this case only make connectivity worse.

Some googling suggested that I turn the option "Smart network switch" off, but it is already off and I still see this behaviour. Is there anything else I can do to make the phone keep the wifi connection regardless of whether I'm "signed in"?

  • Try a VPN hotspot shield application, they MIGHT work but I am not 100% sure. – user80214 Nov 15 '14 at 10:01
  • the VPN method only works for a little while like 2mins or so until it disconnects you because you wernt signed in – user168449 Jun 1 '16 at 11:04
0

You could disable captive portal detection altogether. On Android <= 7.1.1 that is done by:

settings put global captive_portal_detection_enabled 0

For later versions:

settings put global captive_portal_mode 0

For more details please see: Captive Portal parameters.

0

go to a site that updates constantly, keeping the connection alive. Something like "chaturbate" ;-) funny but true

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.