3

I have an issue with my Android 4.4 Nexus 5. When the phone is on either silent or vibrate modes, the alarm is also either silent or just vibrates, which does not wake me up.

I need the alarm to be loud even though my phone is set to vibrate or silent. Currently I'm turning the volume up on my phone just before I go to bed, but that annoys my wife because text messages etc. then wake her up. This is annoying as this is my first phone after coming from iOS for several years, where this wasn't an issue.

I have tried an app to fix this (Persist), but that didn't work. I can probably set a tasker profile up to turn volume on at 6am in the morning, but that seems overkill for what should be a simple fix. I've had very mixed results with third party alarm apps. Lollipop will help in that I will have a "do not disturb feature" again, but that still requires me to ensure my phone is set to ring so I get my alarm to go off properly.

Am I missing something?? Should it be this hard to get an alarm that wakes me up? What do people recommend?

Edit: When I go to Settings > Sounds > Volumes, if the Ringtone & notifications volume is down, the "Alarms" volume is automatically turned off, and I can't change it. In fact the alarm icon even gets a cross through it. So it looks intentional, but I can't for the life of me work out why that would be desired behaviour.

Screenshot
Screenshot (click image for larger variant)

  • 1
    I'm using AlarmDroid as alarm clock. This has a setting to "override alarm volume". Worth a try, I'd say – and please report back if that solves your issue, so I might make it a proper answer ;) – Izzy Nov 19 '14 at 14:40
  • It seems this is a new "feature" introduced some time last week. Everything used to be fine for me too, now I cannot change the alarm volume when the notifications are on silent or vibrate. This sucks even more because I want to make my phone silent so I can take the notifications on my pebble. – sol Jan 17 '15 at 19:21
1

I hate this as well. My solution has been to turn my volume up and put my phone in airplane mode before going to bed, but I wish I didn't have to count on remembering.

1

I know it's a bit late, but you can track the problem down to the source code. In my case, this was set up inside mediatek-framework.jar (mediatek phone), but yours will differ. I edited it so the alarm volume is not changed with the audio profile changes.

Alternatively, if the exact responsible code is not easy to find, I was able to set a fixed non-zero volume for alarms when in Silent or Vibrate by adding a couple of lines of codes in systemui.apk.

Taking advantage of the method that sets up the audio icon in the statusbar when the audio profile is changed, we can make a call such that the alarm volume is set to a value:

const/4 v11, 0x4    # stream_alarm
const/4 v12, 0x9    # volume index
const/4 v13, 0x0    # no flags
invoke-virtual {v1, v11, v12, v13}, Landroid/media/AudioManager;->setStreamVolume(III)V

(v1 refers to "audioManager" which should already be set before)

This is the change in Smali file PhoneStatusBarPolicy (should be similar in any model), just at the beginning of method updateProfile and the call is to the Android class AudioManager, so it should be fine for any phone model.

The volume index is putting volume to number 9, this certainly is subjective and fixed, but at least it will wake you up in case you don't remember to set the alarm volume.

0

Are you using the stock Clock application? If so, have you unchecked "Vibrate" from the alarm settings?

  1. Go to the stock Clock application.
  2. Select the (leftmost) alarm tab in order to configure or add new alarms.
  3. Uncheck "Vibrate."

This should solve the problem. I have the same device, which I usually keep in silent mode, and my alarm is audible.

As a side note, you could put the device in Airplane mode at night so that texts/calls don't come in. Either way, the alarm will still sound normally.

  • Alas - tried this and the alarm is still inaudible. I've updated my question with more information. – Steve Gore Nov 16 '14 at 4:55
0

I'm going to blame a third party app for this - Alarmy (sleep of you can). I had uninstalled it about the time this issue started happening. The solution was to reinstall it, but not have any alarms set. Under Alarmy settings, set the alarm volume. This affects the default clock alarm volume as well.

0

You Can install the "Alarm Clock Xtreme" application and it will sound even if the device is on silent mode. My problem also solved using this application.

0

user140212, you are 100% correct. Not only does Alarm Clock Xtreme sound the alarm when volume sliders are fully down, it doesn't raise any volume sliders after the alarm goes off. IMO this is desirable behavior. Impressive!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.