1

My Samsung Galaxy S3 (GT I9300) does not restart. It does not go into download mode as well. Please Help. Today morning I was checking the weather wizard of my samsung galaxy S3 home screen. Then suddenly the screen got horizontal white, black and pink stripes. I tried back button, home screen button but it kept flashing. Then I even started power off button. Nothing happened for 10-12 seconds. Then suddenly it turned off and at the same time I removed the battery. When I tried to restart it does not boot. I can see the blue LED indicator flashing when I switch on but the screen remains black. It even shows red LED when I tried to charge it. I tried removing battery and replacing, removing sim and even holding start button, home and volume down button to get into download mode. But nothing happens. I can connect to laptop but the folder shows no content. Please help. Thanks!

0

There are two possibilities:

  1. Broken screen

  2. Hard bricked

To find out what you can try doing the fastboot combination for a couple of seconds and then connecting it to your computer and see if it shows up in fastboot devicescommand (with correct drivers installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.